summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2011-09-25 13:22:02 +0200
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2011-09-25 13:42:45 +0200
commit7ef868e88b5e4807d2f88b4b122b9e129434182a (patch)
treec2058f6acaa53fa3df04b31cdbf35bc58690bf81 /src/Makefile.am
parent8ee1bc1d4f559ed2a048bf9c1fa5e3a88eb542c5 (diff)
downloadcmumble-7ef868e88b5e4807d2f88b4b122b9e129434182a.tar.gz
cmumble-7ef868e88b5e4807d2f88b4b122b9e129434182a.tar.bz2
cmumble-7ef868e88b5e4807d2f88b4b122b9e129434182a.zip
Import ocb, needed for OCB-AES-128 encryption in UDP mode
The code is imported since there is no shared library available. It can be retreived from: http://www.cs.ucdavis.edu/~rogaway/ocb/ocb-code.htm
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 567b3f9..6a17f11 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,3 +1,5 @@
+SUBDIRS = ocb
+
bin_PROGRAMS = cmumble
noinst_HEADERS = cmumble.h message.h varint.h io.h \
@@ -9,7 +11,8 @@ cmumble_SOURCES = cmumble.c message.c varint.c io.c \
nodist_cmumble_SOURCES = mumble.pb-c.c
cmumble_LDADD = $(PROTOBUF_LIBS) $(GLIB_LIBS) $(GIO_LIBS) \
- $(GSTREAMER_LIBS) $(CELT_LIBS)
+ $(GSTREAMER_LIBS) $(CELT_LIBS) \
+ ocb/libocb.a
AM_CPPFLAGS = $(PROTOBUF_CFLAGS) $(GLIB_CFLAGS) $(GIO_CFLAGS) \
$(GSTREAMER_CFLAGS) $(CELT_CFLAGS)