summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2011-09-16 14:28:22 +0200
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2012-02-10 09:35:22 +0100
commit269297401c5b63f3f462a66b2e7652e726ad605a (patch)
treecc679b70dd9a3c2c9c23c4932429a192f2d00775 /src/Makefile.am
parentd627f060307c3d6c7d0cabb6f4d66c10f87da214 (diff)
downloadcmumble-269297401c5b63f3f462a66b2e7652e726ad605a.tar.gz
cmumble-269297401c5b63f3f462a66b2e7652e726ad605a.tar.bz2
cmumble-269297401c5b63f3f462a66b2e7652e726ad605a.zip
Derive message type from position in .proto file
This involves changing the .proto file, to actually reflect the type in the protocol.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 567b3f9..18979d0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,12 +18,12 @@ AM_CFLAGS = $(GCC_CFLAGS)
BUILT_SOURCES = $(nodist_cmumble_SOURCES) $(nodist_noinst_HEADERS)
MAINTAINERCLEANFILES = mumble.pb-c.c mumble.pb-c.h
CLEANFILES = message_list.h
-EXTRA_DIST = mumble.proto messages.txt gen_message_list.sed
+EXTRA_DIST = mumble.proto gen_message_list.sed
# Ship files generated by protoc-c in releases,
# so that protoc-c (which pulls in the c++ protobuf) is not needed.
EXTRA_DIST += mumble.pb-c.c mumble.pb-c.h
-message_list.h: $(srcdir)/messages.txt $(srcdir)/gen_message_list.sed
+message_list.h: $(srcdir)/mumble.proto $(srcdir)/gen_message_list.sed
$(AM_V_GEN) LC_ALL= LC_COLLATE=C $(SED) -f $(srcdir)/gen_message_list.sed $< > $@
mumble.pb-c.c mumble.pb-c.h: $(srcdir)/mumble.proto