summaryrefslogtreecommitdiff
path: root/src/ocb/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2011-09-25 13:22:02 +0200
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2012-02-12 13:59:52 +0100
commite0fbfaa64239dd2611f1539173d0de3b053ac779 (patch)
treeb321232a8097bdfb9e14161a462cc9dac9bc5f9b /src/ocb/Makefile.am
parent269297401c5b63f3f462a66b2e7652e726ad605a (diff)
downloadcmumble-e0fbfaa64239dd2611f1539173d0de3b053ac779.tar.gz
cmumble-e0fbfaa64239dd2611f1539173d0de3b053ac779.tar.bz2
cmumble-e0fbfaa64239dd2611f1539173d0de3b053ac779.zip
Import ocb, needed for OCB-AES-128 encryption in UDP mode
The code is imported since there is no shared library available. It can be retreived from: http://www.cs.ucdavis.edu/~rogaway/ocb/ocb-code.htm
Diffstat (limited to 'src/ocb/Makefile.am')
-rw-r--r--src/ocb/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/ocb/Makefile.am b/src/ocb/Makefile.am
new file mode 100644
index 0000000..ce3afa9
--- /dev/null
+++ b/src/ocb/Makefile.am
@@ -0,0 +1,6 @@
+noinst_LIBRARIES = libocb.a
+
+libocb_a_SOURCES = ocb.c rijndael-alg-fst.c \
+ ocb.h rijndael-alg-fst.h
+
+AM_CFLAGS = $(GCC_CFLAGS)