summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fe69d24..fb88fc6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,12 +15,11 @@ AM_CFLAGS = $(GCC_FLAGS)
BUILT_SOURCES = $(nodist_cmumble_SOURCES) $(nodist_noinst_HEADERS)
CLEANFILES = $(BUILT_SOURCES)
-EXTRA_DIST = mumble.proto messages.txt gen_messages.sed protoc-c.sh
+EXTRA_DIST = mumble.proto messages.txt gen_messages.sed
messages.h: $(srcdir)/messages.txt $(srcdir)/gen_messages.sed
$(AM_V_GEN) LC_ALL=C $(SED) -f $(srcdir)/gen_messages.sed $< > $@
mumble.pb-c.c mumble.pb-c.h: $(srcdir)/mumble.proto
- $(AM_V_GEN) PROTOC_C=$(PROTOBUF_EXECUTABLE) \
- $(srcdir)/protoc-c.sh $< $@
+ $(AM_V_GEN) $(builddir)/protoc-c.sh $< $@