summaryrefslogtreecommitdiff
path: root/Source/DirectFB/docs/html/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Source/DirectFB/docs/html/Makefile.am')
-rwxr-xr-xSource/DirectFB/docs/html/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Source/DirectFB/docs/html/Makefile.am b/Source/DirectFB/docs/html/Makefile.am
new file mode 100755
index 0000000..a248e4c
--- /dev/null
+++ b/Source/DirectFB/docs/html/Makefile.am
@@ -0,0 +1,16 @@
+EXTRA_DIST = dfb_logo-alpha.png
+
+docs_headers = \
+ $(top_srcdir)/include/directfb.h \
+ $(top_srcdir)/include/directfb_keyboard.h \
+ $(top_srcdir)/include/directfbgl.h
+
+all-local: stamp-docs
+
+stamp-docs: $(top_srcdir)/tools/gendoc.pl $(docs_headers) Makefile.am
+ rootme=`pwd`; \
+ $(PERL) $(top_srcdir)/tools/gendoc.pl DirectFB $(DIRECTFB_VERSION) $(docs_headers) \
+ && echo timestamp > $$rootme/stamp-docs
+
+distclean-local:
+ rm -f *.html stamp-docs