summaryrefslogtreecommitdiff
path: root/Source/DirectFB/gfxdrivers/cle266/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Source/DirectFB/gfxdrivers/cle266/Makefile.am')
-rwxr-xr-xSource/DirectFB/gfxdrivers/cle266/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/Source/DirectFB/gfxdrivers/cle266/Makefile.am b/Source/DirectFB/gfxdrivers/cle266/Makefile.am
new file mode 100755
index 0000000..fff4976
--- /dev/null
+++ b/Source/DirectFB/gfxdrivers/cle266/Makefile.am
@@ -0,0 +1,47 @@
+## Makefile.am for DirectFB/gfxdrivers/cle266
+
+INCLUDES = \
+ -I$(top_builddir)/include \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/lib \
+ -I$(top_srcdir)/lib \
+ -I$(top_srcdir)/systems \
+ -I$(top_srcdir)/src
+
+AM_CFLAGS = $(DFB_CFLAGS)
+
+cle266_LTLIBRARIES = libdirectfb_cle266.la
+
+if BUILD_STATIC
+cle266_DATA = $(cle266_LTLIBRARIES:.la=.o)
+endif
+
+cle266dir = $(MODULEDIR)/gfxdrivers
+
+libdirectfb_cle266_la_SOURCES = \
+ unichrome.c unichrome.h \
+ uc_accel.c uc_accel.h \
+ uc_hw.h \
+ uc_hwset.c uc_hwmap.c \
+ uc_state.c uc_state.h \
+ uc_fifo.c uc_fifo.h \
+ uc_overlay.c uc_overlay.h \
+ uc_ovl_hwmap.c uc_ovl_hwset.c \
+ uc_primary.c \
+ mmio.h vidregs.h \
+ regs2d.h regs3d.h
+
+libdirectfb_cle266_la_LDFLAGS = \
+ -module \
+ -avoid-version \
+ $(DFB_LDFLAGS)
+
+libdirectfb_cle266_la_LIBADD = \
+ -lm \
+ $(top_builddir)/lib/direct/libdirect.la \
+ $(top_builddir)/lib/fusion/libfusion.la \
+ $(top_builddir)/src/libdirectfb.la
+
+
+include $(top_srcdir)/rules/libobject.make
+