summaryrefslogtreecommitdiff
path: root/Source/DirectFB/inputdrivers/gunze/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Source/DirectFB/inputdrivers/gunze/Makefile.am')
-rwxr-xr-xSource/DirectFB/inputdrivers/gunze/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/Source/DirectFB/inputdrivers/gunze/Makefile.am b/Source/DirectFB/inputdrivers/gunze/Makefile.am
new file mode 100755
index 0000000..ef0b9e6
--- /dev/null
+++ b/Source/DirectFB/inputdrivers/gunze/Makefile.am
@@ -0,0 +1,30 @@
+## Makefile.am for DirectFB/inputdrivers/gunze
+
+INCLUDES = \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/lib \
+ -I$(top_srcdir)/lib \
+ -I$(top_srcdir)/src
+
+input_LTLIBRARIES = libdirectfb_gunze.la
+
+if BUILD_STATIC
+input_DATA = $(input_LTLIBRARIES:.la=.o)
+endif
+
+inputdir = $(MODULEDIR)/inputdrivers
+
+libdirectfb_gunze_la_SOURCES = \
+ gunze.c
+
+libdirectfb_gunze_la_LDFLAGS = \
+ -module \
+ -avoid-version \
+ $(DFB_LDFLAGS)
+
+libdirectfb_gunze_la_LIBADD = \
+ $(top_builddir)/lib/direct/libdirect.la \
+ $(top_builddir)/src/libdirectfb.la
+
+include $(top_srcdir)/rules/libobject.make
+