summaryrefslogtreecommitdiff
path: root/Source/DirectFB/wm/unique/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Source/DirectFB/wm/unique/data/Makefile.am')
-rwxr-xr-xSource/DirectFB/wm/unique/data/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/Source/DirectFB/wm/unique/data/Makefile.am b/Source/DirectFB/wm/unique/data/Makefile.am
new file mode 100755
index 0000000..cd63bfb
--- /dev/null
+++ b/Source/DirectFB/wm/unique/data/Makefile.am
@@ -0,0 +1,31 @@
+## Makefile.am for DirectFB/wm/unique/data
+
+uniquedatadir = $(DATADIR)/unique
+
+all-local: foo.h
+
+clean-local:
+ rm -f foo.h
+
+EXTRA_DIST = \
+ foo_n.png \
+ foo_ne.png \
+ foo_e.png \
+ foo_se.png \
+ foo_s.png \
+ foo_sw.png \
+ foo_w.png \
+ foo_nw.png
+
+if CROSS_COMPILING
+ directfb_csource = $(DIRECTFB_CSOURCE)
+else
+if BUILD_TOOLS
+ directfb_csource = $(top_builddir)/tools/directfb-csource
+else
+ directfb_csource = $(DIRECTFB_CSOURCE)
+endif
+endif
+
+foo.h: $(EXTRA_DIST)
+ $(directfb_csource) --name=foo $(EXTRA_DIST:%=$(srcdir)/%) > foo.h