summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2011-12-14 13:42:21 +0100
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2011-12-14 13:42:21 +0100
commite723c1697c0ec3c0eecbf3797d6c16c69b3cf4ef (patch)
tree1fceedace50a32ad63745981b5182a760387ed44 /configure.ac
parentb952910cafdf565b11bfc171a7028bff5206dbf5 (diff)
downloadpa-sink-ctl-e723c1697c0ec3c0eecbf3797d6c16c69b3cf4ef.tar.gz
pa-sink-ctl-e723c1697c0ec3c0eecbf3797d6c16c69b3cf4ef.tar.bz2
pa-sink-ctl-e723c1697c0ec3c0eecbf3797d6c16c69b3cf4ef.zip
Increase warning leaves, and fix new occured ones
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 81eb2c8..1ef1992 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,7 +36,7 @@ PKG_CHECK_MODULES(PULSE_MAINLOOP, [libpulse-mainloop-glib], [], AC_MSG_ERROR([li
PKG_CHECK_MODULES(GLIB, [glib-2.0], [], AC_MSG_ERROR([glib required]))
if test "x$GCC" = "xyes"; then
- GCC_CFLAGS="-Wall -pedantic -std=c99 -Wstrict-prototypes -Wmissing-prototypes -fvisibility=hidden"
+ GCC_CFLAGS="-Wall -pedantic -std=c99 -W -Wextra -pipe -Wno-long-long -Winline -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing=2 -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option -fvisibility=hidden"
fi
AC_SUBST(GCC_CFLAGS)