summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@gmail.com>2020-02-12 21:39:42 +0100
committerBenjamin Franzke <benjaminfranzke@gmail.com>2020-02-12 21:39:45 +0100
commitcfe267835813b684b9c8ef81b096c2c25263f544 (patch)
treee828f59bea85c7724096d47592df4b0e5925b6f7 /src/Makefile.am
parent244ea507ccbf2d85996e85e15b66bdc857900dd1 (diff)
downloadpa-sink-ctl-cfe267835813b684b9c8ef81b096c2c25263f544.tar.gz
pa-sink-ctl-cfe267835813b684b9c8ef81b096c2c25263f544.tar.bz2
pa-sink-ctl-cfe267835813b684b9c8ef81b096c2c25263f544.zip
Use pkg-config for ncursesw, fallback to classic curses
The fallback is intended for non-ncurses systems only. TODO: add proper check that the fallback lib is wide character capable. (Can't add right now, as we don't know about an incompatiblity)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3579dc0..8c5071c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,7 +7,7 @@ pa_sink_ctl_SOURCES += unix_signal.c
endif
AM_CFLAGS = $(GCC_CFLAGS)
-AM_CPPFLAGS = $(PULSE_CFLAGS) $(PULSE_MAINLOOP_CFLAGS) $(GLIB_CFLAGS) \
+AM_CPPFLAGS = $(PULSE_CFLAGS) $(PULSE_MAINLOOP_CFLAGS) $(GLIB_CFLAGS) $(CURSES_CFLAGS) \
-include $(top_builddir)/config.h
pa_sink_ctl_LDADD = $(GLIB_LIBS) $(PULSE_LIBS) $(PULSE_MAINLOOP_LIBS) $(CURSES_LIBS)