summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2012-01-05 01:16:26 +0100
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2012-01-05 10:27:32 +0100
commitf04d759a3fa1f14d8b8779f4cf6855db4c6f8d8f (patch)
tree53f4df75ff8c3bf95d62fea21cb05cff97eace99 /src/Makefile.am
parentb87627e11f6845e2db24d60702ce681b5910742b (diff)
downloadpa-sink-ctl-f04d759a3fa1f14d8b8779f4cf6855db4c6f8d8f.tar.gz
pa-sink-ctl-f04d759a3fa1f14d8b8779f4cf6855db4c6f8d8f.tar.bz2
pa-sink-ctl-f04d759a3fa1f14d8b8779f4cf6855db4c6f8d8f.zip
Add a manpage using asciidoc
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4401bfa..3579dc0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -12,3 +12,12 @@ AM_CPPFLAGS = $(PULSE_CFLAGS) $(PULSE_MAINLOOP_CFLAGS) $(GLIB_CFLAGS) \
pa_sink_ctl_LDADD = $(GLIB_LIBS) $(PULSE_LIBS) $(PULSE_MAINLOOP_LIBS) $(CURSES_LIBS)
noinst_HEADERS = interface.h command.h config.h pa-sink-ctl.h ctl.h unix_signal.h
+
+dist_man_MANS = pa-sink-ctl.1
+EXTRA_DIST = pa-sink-ctl.1.txt
+
+%: %.txt
+ a2x -f manpage $<
+
+%.html: %.txt
+ a2x -f xhtml -d manpage --stylesheet=pa-sink-ctl-manpage.css $<