summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2011-10-21 11:53:39 +0200
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2011-10-21 23:13:11 +0200
commit2310d43d6410de464dbd5ffa7edc7fd2785f21d3 (patch)
treed6a888b1b973b829a87bad67d210eb3b3d633ed6 /src/Makefile.am
parent478d7fe56a9927133b87b80e21d507c90bd8800d (diff)
downloadpa-sink-ctl-2310d43d6410de464dbd5ffa7edc7fd2785f21d3.tar.gz
pa-sink-ctl-2310d43d6410de464dbd5ffa7edc7fd2785f21d3.tar.bz2
pa-sink-ctl-2310d43d6410de464dbd5ffa7edc7fd2785f21d3.zip
Use a GList instead of GArray for sinks.
This lets us drop our ugly GArray wrappers sink.c and sink_input.c. It will make gradual updates of sinks easier, since elements can be added and dropped everywhere in the list easily.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 863fea4..327376b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
bin_PROGRAMS = pa-sink-ctl
-pa_sink_ctl_SOURCES = interface.c pa-sink-ctl.c sink.c sink_input.c
+pa_sink_ctl_SOURCES = interface.c pa-sink-ctl.c
EXTRA_pa_sink_ctl_SOURCES = unix_signal.c
if !HAVE_SIGNALFD