summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2012-01-05 01:16:26 +0100
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2012-02-27 18:12:44 +0100
commitb88c86f1e7d075b9331feebf6d44a3731ea9354f (patch)
treef724629f8bf3d0679748eb7c74025c3bec11de9b /src/Makefile.am
parenta8799c016e292da05ef9c9168be2d4e5e4f01426 (diff)
downloadpa-sink-ctl-b88c86f1e7d075b9331feebf6d44a3731ea9354f.tar.gz
pa-sink-ctl-b88c86f1e7d075b9331feebf6d44a3731ea9354f.tar.bz2
pa-sink-ctl-b88c86f1e7d075b9331feebf6d44a3731ea9354f.zip
Add a manpage using asciidoc
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4401bfa..3579dc0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -12,3 +12,12 @@ AM_CPPFLAGS = $(PULSE_CFLAGS) $(PULSE_MAINLOOP_CFLAGS) $(GLIB_CFLAGS) \
pa_sink_ctl_LDADD = $(GLIB_LIBS) $(PULSE_LIBS) $(PULSE_MAINLOOP_LIBS) $(CURSES_LIBS)
noinst_HEADERS = interface.h command.h config.h pa-sink-ctl.h ctl.h unix_signal.h
+
+dist_man_MANS = pa-sink-ctl.1
+EXTRA_DIST = pa-sink-ctl.1.txt
+
+%: %.txt
+ a2x -f manpage $<
+
+%.html: %.txt
+ a2x -f xhtml -d manpage --stylesheet=pa-sink-ctl-manpage.css $<