summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4401bfa..3579dc0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -12,3 +12,12 @@ AM_CPPFLAGS = $(PULSE_CFLAGS) $(PULSE_MAINLOOP_CFLAGS) $(GLIB_CFLAGS) \
pa_sink_ctl_LDADD = $(GLIB_LIBS) $(PULSE_LIBS) $(PULSE_MAINLOOP_LIBS) $(CURSES_LIBS)
noinst_HEADERS = interface.h command.h config.h pa-sink-ctl.h ctl.h unix_signal.h
+
+dist_man_MANS = pa-sink-ctl.1
+EXTRA_DIST = pa-sink-ctl.1.txt
+
+%: %.txt
+ a2x -f manpage $<
+
+%.html: %.txt
+ a2x -f xhtml -d manpage --stylesheet=pa-sink-ctl-manpage.css $<