summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2014-01-02 14:57:51 +0100
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2014-01-04 16:10:13 +0100
commit8b09939b9dfb616aa3879118e2d7074484ec3136 (patch)
tree4ad27336b14098894f3925a4cc12e0d33a165102 /configure.ac
parent4aaaded632ceb8c4955a8520f871dbbf94f3447c (diff)
downloadpjctl-8b09939b9dfb616aa3879118e2d7074484ec3136.tar.gz
pjctl-8b09939b9dfb616aa3879118e2d7074484ec3136.tar.bz2
pjctl-8b09939b9dfb616aa3879118e2d7074484ec3136.zip
autoconf/make: Support cygwin compilation
This makes the Makefile.cygwin superfluous. Removed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a353554..ed047dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,15 @@ AC_SUBST([GCC_CFLAGS])
# for src/ext/gnulib/md5.c
AC_C_BIGENDIAN
+AC_CANONICAL_HOST
+have_windows="no"
+case "$host_os" in
+ *cygwin)
+ have_windows="yes"
+ ;;
+esac
+AM_CONDITIONAL([HAVE_WINDOWS], [test "x$have_windows" = "xyes"])
+
AC_CONFIG_FILES([Makefile
src/Makefile])
AC_OUTPUT