summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2014-01-02 14:57:51 +0100
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2014-01-04 16:10:13 +0100
commit8b09939b9dfb616aa3879118e2d7074484ec3136 (patch)
tree4ad27336b14098894f3925a4cc12e0d33a165102 /src/Makefile.am
parent4aaaded632ceb8c4955a8520f871dbbf94f3447c (diff)
downloadpjctl-8b09939b9dfb616aa3879118e2d7074484ec3136.tar.gz
pjctl-8b09939b9dfb616aa3879118e2d7074484ec3136.tar.bz2
pjctl-8b09939b9dfb616aa3879118e2d7074484ec3136.zip
autoconf/make: Support cygwin compilation
This makes the Makefile.cygwin superfluous. Removed.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f9e81a0..2c5ed18 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,7 +2,11 @@ bin_PROGRAMS = pjctl
pjctl_SOURCES = pjctl.c ext/gnulib/md5.c ext/gnulib/md5.h param.h
-pjctl_LDADD = $(crypto_LIBS)
-AM_CPPFLAGS = $(crypto_CFLAGS)
+if HAVE_WINDOWS
+# Create an executable that doesnt open a console
+bin_PROGRAMS += pjctl-no-console
+pjctl_no_console_SOURCES = pjctl.c ext/gnulib/md5.c ext/gnulib/md5.h
+pjctl_no_console_LDFLAGS = -mwindows
+endif
AM_CFLAGS = $(GCC_CFLAGS)