summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..9cee335
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,38 @@
+## Makefile.am for PluggIt/src
+
+AM_CPPFLAGS = -DDATADIR=\"@DATADIR@/\"
+
+INCLUDES = @DFB_CFLAGS@
+LDADD = @DFB_LIBS@ -lX11 -lXext -lXdamage
+
+bin_PROGRAMS = pluggit
+
+pluggit_SOURCES = \
+ classes.cpp
+
+pluggit_LDADD = $(LDADD)
+
+CLASSES = \
+ Exception.cxx \
+ OutOfMemoryException.cxx \
+ \
+ Clock.cxx \
+ FPS.cxx \
+ Options.cxx \
+ Random.cxx \
+ Updates.cxx \
+ \
+ Runnable.cxx \
+ Thread.cxx \
+ \
+ Scaler.cxx \
+ \
+ View.cxx \
+ Source.cxx \
+ SourceX11.cxx \
+ \
+ Main.cxx
+
+classes.cpp: $(CLASSES) *.h Makefile gen_classes.sh main.c
+ ./gen_classes.sh $(CLASSES) > classes.cpp
+