summaryrefslogtreecommitdiff
path: root/examples/VFS/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2003-06-06 07:09:30 +0000
committerJeremy Allison <jra@samba.org>2003-06-06 07:09:30 +0000
commitde3f1c77677c80cb27688521b39c5325bb4e3bd7 (patch)
tree8e15b5a5604cc8b01ce9c649c50262a27946b623 /examples/VFS/configure.in
parentdff2bf904e7b53bc23cccbe9c4bf1844f27dbfe0 (diff)
downloadsamba-de3f1c77677c80cb27688521b39c5325bb4e3bd7.tar.gz
samba-de3f1c77677c80cb27688521b39c5325bb4e3bd7.tar.bz2
samba-de3f1c77677c80cb27688521b39c5325bb4e3bd7.zip
Make skeleton VFSs compile with new EA modules.
Jeremy (This used to be commit 7c4cc2086d59e163ab89366c24ba399994a49462)
Diffstat (limited to 'examples/VFS/configure.in')
-rw-r--r--examples/VFS/configure.in78
1 files changed, 78 insertions, 0 deletions
diff --git a/examples/VFS/configure.in b/examples/VFS/configure.in
index 8e6c517fed..a0d1dc9630 100644
--- a/examples/VFS/configure.in
+++ b/examples/VFS/configure.in
@@ -83,6 +83,84 @@ then
CFLAGS="-O ${CFLAGS}"
fi
+ #################################################
+ # check for krb5-config from recent MIT and Heimdal kerberos 5
+ AC_PATH_PROG(KRB5_CONFIG, krb5-config)
+ AC_MSG_CHECKING(for working krb5-config)
+ if test -x "$KRB5_CONFIG"; then
+ CFLAGS="$CFLAGS `$KRB5_CONFIG --cflags | sed s/@INCLUDE_des@//`"
+ CPPFLAGS="$CPPFLAGS `$KRB5_CONFIG --cflags | sed s/@INCLUDE_des@//`"
+ FOUND_KRB5=yes
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no. Fallback to previous krb5 detection strategy)
+ fi
+
+ if test x$FOUND_KRB5 = x"no"; then
+ #################################################
+ # check for location of Kerberos 5 install
+ AC_MSG_CHECKING(for kerberos 5 install path)
+ AC_ARG_WITH(krb5,
+ [ --with-krb5=base-dir Locate Kerberos 5 support (default=/usr)],
+ [ case "$withval" in
+ no)
+ AC_MSG_RESULT(no)
+ ;;
+ *)
+ AC_MSG_RESULT(yes)
+ CFLAGS="$CFLAGS -I$withval/include"
+ CPPFLAGS="$CPPFLAGS -I$withval/include"
+ FOUND_KRB5=yes
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+ )
+ fi
+
+if test x$FOUND_KRB5 = x"no"; then
+#################################################
+# see if this box has the SuSE location for the heimdal kerberos implementation
+AC_MSG_CHECKING(for /usr/include/heimdal)
+if test -d /usr/include/heimdal; then
+ if test -f /usr/lib/heimdal/lib/libkrb5.a; then
+ CFLAGS="$CFLAGS -I/usr/include/heimdal"
+ CPPFLAGS="$CPPFLAGS -I/usr/include/heimdal"
+ AC_MSG_RESULT(yes)
+ else
+ CFLAGS="$CFLAGS -I/usr/include/heimdal"
+ CPPFLAGS="$CPPFLAGS -I/usr/include/heimdal"
+ AC_MSG_RESULT(yes)
+
+ fi
+else
+ AC_MSG_RESULT(no)
+fi
+fi
+
+
+if test x$FOUND_KRB5 = x"no"; then
+#################################################
+# see if this box has the RedHat location for kerberos
+AC_MSG_CHECKING(for /usr/kerberos)
+if test -d /usr/kerberos -a -f /usr/kerberos/lib/libkrb5.a; then
+ LDFLAGS="$LDFLAGS -L/usr/kerberos/lib"
+ CFLAGS="$CFLAGS -I/usr/kerberos/include"
+ CPPFLAGS="$CPPFLAGS -I/usr/kerberos/include"
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+fi
+
+ # now check for krb5.h. Some systems have the libraries without the headers!
+ # note that this check is done here to allow for different kerberos
+ # include paths
+ AC_CHECK_HEADERS(krb5.h)
+
+ # now check for gssapi headers. This is also done here to allow for
+ # different kerberos include paths
+ AC_CHECK_HEADERS(gssapi.h gssapi/gssapi_generic.h gssapi/gssapi.h com_err.h)
+
#dnl Check if we use GNU ld
#LD=ld
#AC_PROG_LD_GNU