summaryrefslogtreecommitdiff
path: root/packaging/Debian/debian-unstable/scripts/patch-source
diff options
context:
space:
mode:
authorSimo Sorce <idra@samba.org>2004-05-14 12:42:42 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 10:51:35 -0500
commitc32c36d96f3a7863ab8514456e8a0eb9e4839264 (patch)
treedfc31bfe53dea0b3460f8c5f823d8d9ed65c13ec /packaging/Debian/debian-unstable/scripts/patch-source
parent400bed7a68ccdeeb8c50326e817788e01b155907 (diff)
downloadsamba-c32c36d96f3a7863ab8514456e8a0eb9e4839264.tar.gz
samba-c32c36d96f3a7863ab8514456e8a0eb9e4839264.tar.bz2
samba-c32c36d96f3a7863ab8514456e8a0eb9e4839264.zip
r730: move the current debian dir to debian-unstable
(This used to be commit 65022f1dde7012a8c8c1872ad87184531973b5c5)
Diffstat (limited to 'packaging/Debian/debian-unstable/scripts/patch-source')
-rwxr-xr-xpackaging/Debian/debian-unstable/scripts/patch-source28
1 files changed, 28 insertions, 0 deletions
diff --git a/packaging/Debian/debian-unstable/scripts/patch-source b/packaging/Debian/debian-unstable/scripts/patch-source
new file mode 100755
index 0000000000..a8559b4167
--- /dev/null
+++ b/packaging/Debian/debian-unstable/scripts/patch-source
@@ -0,0 +1,28 @@
+#!/bin/sh -e
+#
+#
+
+for patch in debian/patches/*.patch; do
+ echo '->'`basename $patch`:
+ patch -p1 --ignore-whitespace < $patch
+done
+
+# This code is currently not used because it creates a long version
+# number string. For now we're sticking to <upstream version>-Debian,
+# as in 3.0.0rc2-Debian. peloy@debian.org.-
+
+# ---- Begin unused code ----
+# Get Debian version number from 1st line of the Debian changelog
+#DEBIAN_VERSION=`sed -n -e '1s/^.*(\(.*\)).*$/\1/p' debian/changelog`
+
+# Insert Debian version number in source/VERSION, which will then be
+# used to create source/include/version.h.
+#TMPFILE=source/VERSION.debian
+#sed -e "s/^\(SAMBA_VERSION_VENDOR_SUFFIX=\).*$/\1\"Debian-${DEBIAN_VERSION}\"/" source/VERSION > ${TMPFILE}
+#mv -f ${TMPFILE} source/VERSION
+# ---- End unused code ----
+
+# Regenerate configure only if it is older than configure.in
+[ source/configure -ot source/configure.in ] && (cd source && sh ./autogen.sh)
+
+exit 0