summaryrefslogtreecommitdiff
path: root/packaging/Debian/debian-woody/scripts
diff options
context:
space:
mode:
authorSimo Sorce <idra@samba.org>2005-10-29 13:19:27 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 11:05:15 -0500
commitfa75e8c1d482cdbad2ff074eccb2baf8d5bba856 (patch)
tree51797882a25cfdd23dc653d80cd5cf1723cc6f42 /packaging/Debian/debian-woody/scripts
parent3a5c37bfd12781077fe8e7c6ebb23c2cfdb77fd1 (diff)
downloadsamba-fa75e8c1d482cdbad2ff074eccb2baf8d5bba856.tar.gz
samba-fa75e8c1d482cdbad2ff074eccb2baf8d5bba856.tar.bz2
samba-fa75e8c1d482cdbad2ff074eccb2baf8d5bba856.zip
r11395: Update the Debian packaging.
Move form stable to stable distribution names based hives. (This used to be commit bb13b3482047b6ab6d84ba9e2839cf8a0fac71aa)
Diffstat (limited to 'packaging/Debian/debian-woody/scripts')
-rwxr-xr-xpackaging/Debian/debian-woody/scripts/patch-source28
-rwxr-xr-xpackaging/Debian/debian-woody/scripts/unpatch-source20
2 files changed, 48 insertions, 0 deletions
diff --git a/packaging/Debian/debian-woody/scripts/patch-source b/packaging/Debian/debian-woody/scripts/patch-source
new file mode 100755
index 0000000000..a8559b4167
--- /dev/null
+++ b/packaging/Debian/debian-woody/scripts/patch-source
@@ -0,0 +1,28 @@
+#!/bin/sh -e
+#
+#
+
+for patch in debian/patches/*.patch; do
+ echo '->'`basename $patch`:
+ patch -p1 --ignore-whitespace < $patch
+done
+
+# This code is currently not used because it creates a long version
+# number string. For now we're sticking to <upstream version>-Debian,
+# as in 3.0.0rc2-Debian. peloy@debian.org.-
+
+# ---- Begin unused code ----
+# Get Debian version number from 1st line of the Debian changelog
+#DEBIAN_VERSION=`sed -n -e '1s/^.*(\(.*\)).*$/\1/p' debian/changelog`
+
+# Insert Debian version number in source/VERSION, which will then be
+# used to create source/include/version.h.
+#TMPFILE=source/VERSION.debian
+#sed -e "s/^\(SAMBA_VERSION_VENDOR_SUFFIX=\).*$/\1\"Debian-${DEBIAN_VERSION}\"/" source/VERSION > ${TMPFILE}
+#mv -f ${TMPFILE} source/VERSION
+# ---- End unused code ----
+
+# Regenerate configure only if it is older than configure.in
+[ source/configure -ot source/configure.in ] && (cd source && sh ./autogen.sh)
+
+exit 0
diff --git a/packaging/Debian/debian-woody/scripts/unpatch-source b/packaging/Debian/debian-woody/scripts/unpatch-source
new file mode 100755
index 0000000000..d3681cfa50
--- /dev/null
+++ b/packaging/Debian/debian-woody/scripts/unpatch-source
@@ -0,0 +1,20 @@
+#!/bin/sh -e
+#
+#
+
+# We want to reverse the patches in the opposite order we applied
+# them, hence the 'ls|sort -r'.
+for patch in `ls debian/patches/*.patch | sort -r`; do
+ patch -p1 -R --ignore-whitespace < $patch
+done
+
+# Unused code. See comment in the patch-source script.
+
+#TMPFILE=source/VERSION.debian
+#sed -e "s/^\(SAMBA_VERSION_VENDOR_SUFFIX=\).*$/\1/" source/VERSION > ${TMPFILE}
+#mv -f ${TMPFILE} source/VERSION
+
+# Regenerate configure only if it is older than configure.in
+[ source/configure -ot source/configure.in ] && (cd source && autoheader && autoconf)
+
+exit 0