summaryrefslogtreecommitdiff
path: root/packaging/Debian/debian/rules
diff options
context:
space:
mode:
authorEloy Paris <peloy@samba.org>2003-07-03 04:06:28 +0000
committerEloy Paris <peloy@samba.org>2003-07-03 04:06:28 +0000
commit91100b67e63e5ac127af92a0bc70bcfa53c64be3 (patch)
treec7e53390785a54d00a3c11f6710af0e1f015399f /packaging/Debian/debian/rules
parenta31a2c159cd51112abdbe230c7a4df743fe14288 (diff)
downloadsamba-91100b67e63e5ac127af92a0bc70bcfa53c64be3.tar.gz
samba-91100b67e63e5ac127af92a0bc70bcfa53c64be3.tar.bz2
samba-91100b67e63e5ac127af92a0bc70bcfa53c64be3.zip
More Debian updates.
(This used to be commit 1f7de8c42e05c70cdb76c4f917b7ff128f5249e6)
Diffstat (limited to 'packaging/Debian/debian/rules')
-rwxr-xr-xpackaging/Debian/debian/rules18
1 files changed, 17 insertions, 1 deletions
diff --git a/packaging/Debian/debian/rules b/packaging/Debian/debian/rules
index 4cef604f8e..a8c83529a4 100755
--- a/packaging/Debian/debian/rules
+++ b/packaging/Debian/debian/rules
@@ -23,6 +23,22 @@ DEB_BUILD_GNU_TYPE := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
export DEB_HOST_GNU_TYPE
export DEB_BUILD_GNU_TYPE
+
+# Support the DEB_BUILD_OPTIONS variable
+CFLAGS = -gstabs -Wall
+INSTALL = install
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL += -s
+endif
+
+
DESTDIR=`pwd`/debian/tmp
SWATDIR=`pwd`/debian/swat
SAMBABOOK=`pwd`/debian/swat
@@ -60,7 +76,7 @@ configure-stamp:
cp -f debian/config.cache source/config.cache; \
fi
- [ -f source/Makefile ] || (cd source && ./configure \
+ [ -f source/Makefile ] || (cd source && CFLAGS="$(CFLAGS)" ./configure \
--host=$(DEB_HOST_GNU_TYPE) \
--build=$(DEB_BUILD_GNU_TYPE) \
--cache-file=./config.cache \