summaryrefslogtreecommitdiff
path: root/packaging/Debian/debian/scripts/unpatch-source
diff options
context:
space:
mode:
authorEloy Paris <peloy@samba.org>2003-06-01 04:30:13 +0000
committerEloy Paris <peloy@samba.org>2003-06-01 04:30:13 +0000
commit72cc0c82c415c872e270d924c795d6ac907a32fb (patch)
treedd0b7cb81c75fe123179988c264e445383eb25ed /packaging/Debian/debian/scripts/unpatch-source
parentdbd4a83c7ffbf7043e085c5382f55cf336daf27e (diff)
downloadsamba-72cc0c82c415c872e270d924c795d6ac907a32fb.tar.gz
samba-72cc0c82c415c872e270d924c795d6ac907a32fb.tar.bz2
samba-72cc0c82c415c872e270d924c795d6ac907a32fb.zip
Bringing packaging/Debian/ up to date with the current Samba package
in Debian unstable. The stuff here was ages old... (This used to be commit 5646df8bfb327d74f9c07fc219023a5aecdbc70d)
Diffstat (limited to 'packaging/Debian/debian/scripts/unpatch-source')
-rwxr-xr-xpackaging/Debian/debian/scripts/unpatch-source12
1 files changed, 11 insertions, 1 deletions
diff --git a/packaging/Debian/debian/scripts/unpatch-source b/packaging/Debian/debian/scripts/unpatch-source
index 81d51f7dd4..92014982fc 100755
--- a/packaging/Debian/debian/scripts/unpatch-source
+++ b/packaging/Debian/debian/scripts/unpatch-source
@@ -1,7 +1,17 @@
#!/bin/sh -e
+#
+# $Id: unpatch-source,v 1.2.4.1 2003/06/01 04:30:13 peloy Exp $
+#
-for patch in debian/patches/*.patch; do
+# We want to reverse the patches in the opposite order we applied
+# them, hence the 'ls|sort -r'.
+for patch in `ls debian/patches/*.patch | sort -r`; do
patch -p1 -R < $patch
done
+perl -pi -e's/-.* for Debian//' source/include/version.h
+
+# Regenerate configure only if it is older than configure.in
+[ source/configure -ot source/configure.in ] && (cd source && autoheader && autoconf)
+
exit 0