summaryrefslogtreecommitdiff
path: root/packaging/Debian/debian/scripts
diff options
context:
space:
mode:
authorEloy Paris <peloy@samba.org>2003-09-08 14:48:09 +0000
committerEloy Paris <peloy@samba.org>2003-09-08 14:48:09 +0000
commit657e9fa191c76b1ce41aa4c44e0626104c65bfa8 (patch)
tree4dbcd51e6702334c89922c8927f67f635b9e9bb6 /packaging/Debian/debian/scripts
parent7a0b58a012590009a0d05430ea0c75ac4509830c (diff)
downloadsamba-657e9fa191c76b1ce41aa4c44e0626104c65bfa8.tar.gz
samba-657e9fa191c76b1ce41aa4c44e0626104c65bfa8.tar.bz2
samba-657e9fa191c76b1ce41aa4c44e0626104c65bfa8.zip
Sync'ing packaging/Debian/ with the latest files from the official
Debian packages. This files are in sync. with the Debian packages for 3.0.0rc2. (This used to be commit 7d8d193c05d60ab9b86d52075bb9ec5ad1857903)
Diffstat (limited to 'packaging/Debian/debian/scripts')
-rwxr-xr-xpackaging/Debian/debian/scripts/patch-source18
-rwxr-xr-xpackaging/Debian/debian/scripts/unpatch-source8
2 files changed, 21 insertions, 5 deletions
diff --git a/packaging/Debian/debian/scripts/patch-source b/packaging/Debian/debian/scripts/patch-source
index aabcbf709c..a8559b4167 100755
--- a/packaging/Debian/debian/scripts/patch-source
+++ b/packaging/Debian/debian/scripts/patch-source
@@ -4,11 +4,23 @@
for patch in debian/patches/*.patch; do
echo '->'`basename $patch`:
- patch -p1 < $patch
+ patch -p1 --ignore-whitespace < $patch
done
-cat debian/changelog | perl -pi -e '($version) = <STDIN> =~/\((.*)\)/; \
- s/\".*\"/\"$version for Debian\"/' source/include/version.h
+# This code is currently not used because it creates a long version
+# number string. For now we're sticking to <upstream version>-Debian,
+# as in 3.0.0rc2-Debian. peloy@debian.org.-
+
+# ---- Begin unused code ----
+# Get Debian version number from 1st line of the Debian changelog
+#DEBIAN_VERSION=`sed -n -e '1s/^.*(\(.*\)).*$/\1/p' debian/changelog`
+
+# Insert Debian version number in source/VERSION, which will then be
+# used to create source/include/version.h.
+#TMPFILE=source/VERSION.debian
+#sed -e "s/^\(SAMBA_VERSION_VENDOR_SUFFIX=\).*$/\1\"Debian-${DEBIAN_VERSION}\"/" source/VERSION > ${TMPFILE}
+#mv -f ${TMPFILE} source/VERSION
+# ---- End unused code ----
# Regenerate configure only if it is older than configure.in
[ source/configure -ot source/configure.in ] && (cd source && sh ./autogen.sh)
diff --git a/packaging/Debian/debian/scripts/unpatch-source b/packaging/Debian/debian/scripts/unpatch-source
index 0f577d362f..d3681cfa50 100755
--- a/packaging/Debian/debian/scripts/unpatch-source
+++ b/packaging/Debian/debian/scripts/unpatch-source
@@ -5,10 +5,14 @@
# We want to reverse the patches in the opposite order we applied
# them, hence the 'ls|sort -r'.
for patch in `ls debian/patches/*.patch | sort -r`; do
- patch -p1 -R < $patch
+ patch -p1 -R --ignore-whitespace < $patch
done
-perl -pi -e's/-.* for Debian//' source/include/version.h
+# Unused code. See comment in the patch-source script.
+
+#TMPFILE=source/VERSION.debian
+#sed -e "s/^\(SAMBA_VERSION_VENDOR_SUFFIX=\).*$/\1/" source/VERSION > ${TMPFILE}
+#mv -f ${TMPFILE} source/VERSION
# Regenerate configure only if it is older than configure.in
[ source/configure -ot source/configure.in ] && (cd source && autoheader && autoconf)