summaryrefslogtreecommitdiff
path: root/packaging/debian/rules
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2006-11-07 14:06:58 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 14:25:16 -0500
commit8b063f9843d46a9b539f4295a762c65c21c6aa64 (patch)
tree21f26c6a43ff454e72cb6442925d131106cf3a9c /packaging/debian/rules
parentddc938245609beb5f1b3cdecabf67e06c1d42d0a (diff)
downloadsamba-8b063f9843d46a9b539f4295a762c65c21c6aa64.tar.gz
samba-8b063f9843d46a9b539f4295a762c65c21c6aa64.tar.bz2
samba-8b063f9843d46a9b539f4295a762c65c21c6aa64.zip
r19620: Remove old (outdated) files.
(This used to be commit 3bec179de6208d396b65a2cbe98efcbd7d99e242)
Diffstat (limited to 'packaging/debian/rules')
-rwxr-xr-xpackaging/debian/rules96
1 files changed, 0 insertions, 96 deletions
diff --git a/packaging/debian/rules b/packaging/debian/rules
deleted file mode 100755
index 7938256cf7..0000000000
--- a/packaging/debian/rules
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/usr/bin/make -f
-# By Jelmer Vernooij <jelmer@samba.org>
-# Made with the aid of debmake, by Christoph Lameter,
-# based on the sample debian/rules file for GNU hello by Ian Jackson.
-
-SOURCEPATH=../source
-
-package=samba
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- cd $(SOURCEPATH) && ./autogen.sh
- cd $(SOURCEPATH) && ./configure --with-fhs \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --enable-shared \
- --enable-static \
- --sysconfdir=/etc \
- --libdir=/etc/samba \
- --with-configdir=/etc/samba \
- --with-privatedir=/etc/samba \
- --with-piddir=/var/run/samba \
- --localstatedir=/var \
- --with-pam \
- --with-syslog \
- --with-readline \
- --with-ldap
- cd $(SOURCEPATH)/pidl && perl Makefile.PL verbose INSTALLDIRS=vendor PREFIX=/usr
- touch $@
-
-build: build-stamp
-build-stamp: configure
- dh_testdir
- $(MAKE) -C $(SOURCEPATH) proto
- -$(MAKE) -C $(SOURCEPATH) pch
- $(MAKE) -C $(SOURCEPATH) all
- $(MAKE) -C $(SOURCEPATH)/pidl all
- touch $@
-
-clean:
- dh_testdir
- dh_testroot
- dh_clean
- $(RM) debian/tmp
- -$(MAKE) -C $(SOURCEPATH) clean
- $(RM) build-stamp configure-stamp
-
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_install -i --sourcedir=debian/tmp
- dh_installdocs -i
- dh_installchangelogs -i
- dh_compress -i
- dh_fixperms -i
- dh_installdeb -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-# There are no architecture-independent files to be uploaded
-# generated by this package. If there were any they would be
-# made here.
-
-install: build
- dh_clean -k
- dh_installdirs
- mkdir -p $(CURDIR)/debian/tmp/usr/share/man/man1
- mkdir -p $(CURDIR)/debian/tmp/etc/samba
- $(MAKE) -C $(SOURCEPATH) install DESTDIR=$(CURDIR)/debian/tmp
- $(MAKE) -C $(SOURCEPATH) manpages installman DESTDIR=$(CURDIR)/debian/tmp
- cp $(SOURCEPATH)/setup/provision $(CURDIR)/debian/tmp/usr/lib/samba/setup
- $(MAKE) -C $(SOURCEPATH)/pidl install DESTDIR=$(CURDIR)/debian/tmp
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_install -a --sourcedir=debian/tmp
- dh_installdocs -a
- dh_installchangelogs -a
- dh_strip -a
- dh_perl -a
- dh_compress -a
- dh_fixperms -a
- dh_makeshlibs -a
- dh_installinit -a --name=samba
- dh_installdebconf -a
- dh_installdeb -a
- dh_shlibdeps -a
- dh_gencontrol -a
- dh_md5sums -a
- dh_builddeb -a
-
-binary: binary-arch binary-indep
-
-.PHONY: configure build install binary binary-arch binary-indep clean