summaryrefslogtreecommitdiff
path: root/packaging/debian
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2005-05-14 16:41:53 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 13:16:43 -0500
commit770b47415d717871eecab4d9a91cc1945609c587 (patch)
tree267ef4c71eb8ce2b67b163b2bb4d3a4ba23d6c7e /packaging/debian
parent6f760656907efde6f96bed0e97380b7da7eb045f (diff)
downloadsamba-770b47415d717871eecab4d9a91cc1945609c587.tar.gz
samba-770b47415d717871eecab4d9a91cc1945609c587.tar.bz2
samba-770b47415d717871eecab4d9a91cc1945609c587.zip
r6787: Use debhelper for the debian packages
(This used to be commit 9f1b15832d4a8bc9914751811fd10f6a35265b8d)
Diffstat (limited to 'packaging/debian')
-rw-r--r--packaging/debian/control12
-rw-r--r--packaging/debian/dirs2
-rwxr-xr-xpackaging/debian/rules73
-rw-r--r--packaging/debian/samba4-common.conffiles1
-rw-r--r--packaging/debian/samba4-gtk-frontends.files (renamed from packaging/debian/gregedit.files)1
5 files changed, 49 insertions, 40 deletions
diff --git a/packaging/debian/control b/packaging/debian/control
index 67bba25531..14bdbc6008 100644
--- a/packaging/debian/control
+++ b/packaging/debian/control
@@ -2,8 +2,8 @@ Source: samba4
Section: net
Priority: optional
Maintainer: Jelmer Vernooij <jelmer@samba.org>
-Standards-Version: 3.5.8
-Build-Depends: debmake, libgtk2.0-dev, libgconf2-dev, libldap-dev
+Standards-Version: 3.6.1.0
+Build-Depends: debmake, libgtk2.0-dev, libgconf2-dev, libldap-dev, debhelper (>> 4.0.0)
Package: samba4
Architecture: any
@@ -31,10 +31,10 @@ Description: Testsuite from Samba4
Package: samba4-server
Architecture: any
Depends: ${shlibs:Depends}, samba4-common
-Description: GPL'ed SMB Server
- Contains smbd, the Samba server.
+Description: SMB Server
+ Contains smbd, the Samba server.
-Package: gregedit
+Package: samba4-gtk-frontends
Architecture: any
Depends: ${shlibs:Depends}
Description: Graphical tool for viewing and editing registry files
@@ -60,7 +60,7 @@ Description: IDL compiler written in Perl
Package: samba4-dev
Architecture: any
-Depends: pidl
+Depends: pidl, libc6-dev, pkg-config (>= 0.14.0)
Description: Tools for extending Samba
Contains Samba includes and tools
diff --git a/packaging/debian/dirs b/packaging/debian/dirs
index ca882bbb78..ff8f151762 100644
--- a/packaging/debian/dirs
+++ b/packaging/debian/dirs
@@ -1,2 +1,4 @@
usr/bin
usr/sbin
+usr/share/man/man1
+usr/share/man/man7
diff --git a/packaging/debian/rules b/packaging/debian/rules
index 113347e4e5..7b303f728e 100755
--- a/packaging/debian/rules
+++ b/packaging/debian/rules
@@ -1,15 +1,14 @@
#!/usr/bin/make -f
-# By Jelmer Vernooij
+# By Jelmer Vernooij <jelmer@samba.org>
# Made with the aid of debmake, by Christoph Lameter,
# based on the sample debian/rules file for GNU hello by Ian Jackson.
-
SOURCEPATH=../../source
package=samba4
configure:
- $(checkdir)
+ dh_testdir
cd $(SOURCEPATH) && ./autogen.sh
cd $(SOURCEPATH) && ./configure --with-fhs \
--prefix=/usr \
@@ -24,50 +23,56 @@ configure:
--with-syslog \
--with-readline \
--with-ldap
- touch configure
+ touch $@
build: configure
- $(checkdir)
+ dh_testdir
cd $(SOURCEPATH) && $(MAKE) proto all
- touch build
+ touch $@
clean:
- $(checkdir)
+ dh_testdir
+ dh_clean
rm -f build
-cd $(SOURCEPATH) && $(MAKE) clean
- rm -f `find . -name "*~"`
- rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
- rm -f debian/*substvars
-binary-indep: checkroot build
- $(checkdir)
+binary-indep: build install
+ dh_testdir -i
+ dh_testroot -i
+ dh_installdocs -i
+ dh_installchangelogs -i
+ dh_compress -i
+ dh_fixperms -i
+ dh_python -i
+ dh_installdeb -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
# There are no architecture-independent files to be uploaded
# generated by this package. If there were any they would be
# made here.
-binary-arch: checkroot build
- $(checkdir)
- rm -rf debian/tmp `find debian/* -type d ! -name CVS`
- install -d debian/tmp
- cd debian/tmp && install -d `cat ../dirs`
- cd $(SOURCEPATH) && $(MAKE) install DESTDIR=`pwd`/../packaging/debian/tmp
- mkdir -p debian/tmp/usr/share/man/man1
- mkdir -p debian/tmp/usr/share/man/man7
- cp $(SOURCEPATH)/build/pidl/pidl.pl debian/tmp/usr/bin/pidl
- debstd
- dpkg-gencontrol -isp -psamba4
- chown -R root:root debian/tmp
- chmod -R go=rX debian/tmp
- dpkg --build debian/tmp ..
+install: build
+ dh_clean -k
+ dh_installdirs
+ $(MAKE) -C $(SOURCEPATH) install DESTDIR=`pwd`/../packaging/debian/tmp
-define checkdir
- test -f debian/rules
-endef
+binary-arch: build install
+ dh_testdir -a
+ dh_testroot -a
+ dh_installdocs -a
+ dh_installman -a
+ dh_strip -a
+ dh_python -a
+ dh_compress -a
+ dh_fixperms -a
+ dh_makeshlibs -a
+ dh_installdeb -a
+ dh_shlibdeps -a
+ dh_gencontrol -a
+ dh_md5sums -a
+ dh_builddeb -a
binary: binary-indep binary-arch
-checkroot:
- $(checkdir)
- test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot
+.PHONY: binary binary-arch binary-indep clean
diff --git a/packaging/debian/samba4-common.conffiles b/packaging/debian/samba4-common.conffiles
new file mode 100644
index 0000000000..69f3994af2
--- /dev/null
+++ b/packaging/debian/samba4-common.conffiles
@@ -0,0 +1 @@
+etc/samba4/smb.conf
diff --git a/packaging/debian/gregedit.files b/packaging/debian/samba4-gtk-frontends.files
index eb4b95c7b2..747b87dc5b 100644
--- a/packaging/debian/gregedit.files
+++ b/packaging/debian/samba4-gtk-frontends.files
@@ -1,2 +1,3 @@
usr/bin/gregedit
+usr/bin/gwsam
usr/share/man/man1/gregedit.1