summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMartin Pool <mbp@samba.org>2002-09-09 06:05:39 +0000
committerMartin Pool <mbp@samba.org>2002-09-09 06:05:39 +0000
commit01e7afadd6b49b3174623c637ec21d5abf7bc782 (patch)
treee1ec68c000ec0fbb33ba2df8a5ac64842af06868 /source3/configure.in
parentb15ffb766a223db7a514705fd056944e0c9098e9 (diff)
downloadsamba-01e7afadd6b49b3174623c637ec21d5abf7bc782.tar.gz
samba-01e7afadd6b49b3174623c637ec21d5abf7bc782.tar.bz2
samba-01e7afadd6b49b3174623c637ec21d5abf7bc782.zip
Add --with-python=PYTHONNAME configure option, so that the libraries
get linked for the appropriate version. (This used to be commit 2ea647bbfaba5a4ee7cb232ae1a21acbd2a9b5c6)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index baeebd6654..3a75b32aaf 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2807,6 +2807,19 @@ AC_SUBST(BUILD_POPT)
AC_SUBST(FLAGS1)
#################################################
+# Check if the user wants Python
+
+# At the moment, you can use this to set which Python binary to link
+# against. (Libraries built for Python2.2 can't be used by 2.1,
+# though they can coexist in different directories.) In the future
+# this might make the Python stuff be built by default.
+
+AC_ARG_WITH(python,
+[ --with-python=PYTHONNAME build Python libraries],
+[ PYTHON=${withval-python} ])
+AC_SUBST(PYTHON)
+
+#################################################
# do extra things if we are running insure
if test "${ac_cv_prog_CC}" = "insure"; then