summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2002-10-03 04:19:52 +0000
committerAndrew Bartlett <abartlet@samba.org>2002-10-03 04:19:52 +0000
commit1a9703338cbccb4e95b8dcf01b770313f46c48e8 (patch)
tree63c4e5f7a768c404a71f1659ca058852d7e530d5 /source3/configure.in
parent08387abd7d6f581dd1954fe05b7b28a1fa71bcd8 (diff)
downloadsamba-1a9703338cbccb4e95b8dcf01b770313f46c48e8.tar.gz
samba-1a9703338cbccb4e95b8dcf01b770313f46c48e8.tar.bz2
samba-1a9703338cbccb4e95b8dcf01b770313f46c48e8.zip
Patch from Steve Langasek <vorlon@netexpress.net>:
(quoting his mail) Ok, here's round two of splitting up the library dependencies. I think the first one's been steeping in CVS for long enough now. This splits off the "authentication" libs (libpam, libcrypt) into their own group. A modest gain, but you've gotta start somewhere. Steve Langasek postmodern programmer (This used to be commit a1c63d04b87375dc98dc78781eaf1812bfb1db2b)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in12
1 files changed, 8 insertions, 4 deletions
diff --git a/source3/configure.in b/source3/configure.in
index e9ad6af93e..81898e6af7 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -148,6 +148,7 @@ AC_SUBST(SHLIBEXT)
AC_SUBST(LIBSMBCLIENT_SHARED)
AC_SUBST(LIBSMBCLIENT)
AC_SUBST(PRINTLIBS)
+AC_SUBST(AUTHLIBS)
# compile with optimization and without debugging by default
CFLAGS="-O ${CFLAGS}"
@@ -613,7 +614,7 @@ AC_FUNC_MEMCMP
# test for where we get crypt() from
AC_CHECK_FUNCS(crypt)
if test x"$ac_cv_func_crypt" = x"no"; then
- AC_CHECK_LIB(crypt, crypt, [LIBS="$LIBS -lcrypt";
+ AC_CHECK_LIB(crypt, crypt, [AUTHLIBS="$AUTHLIBS -lcrypt";
AC_DEFINE(HAVE_CRYPT)])
fi
@@ -2123,7 +2124,7 @@ AC_ARG_WITH(pam,
yes)
AC_MSG_RESULT(yes)
AC_DEFINE(WITH_PAM)
- LIBS="$LIBS -lpam"
+ AUTHLIBS="$AUTHLIBS -lpam"
with_pam_for_crypt=yes
;;
*)
@@ -2171,7 +2172,7 @@ AC_ARG_WITH(pam_smbpass,
if test x"$with_pam_for_crypt" = x"no"; then
AC_CHECK_FUNCS(crypt)
if test x"$ac_cv_func_crypt" = x"no"; then
- AC_CHECK_LIB(crypt, crypt, [LIBS="$LIBS -lcrypt";
+ AC_CHECK_LIB(crypt, crypt, [AUTHLIBS="$AUTHLIBS -lcrypt";
AC_DEFINE(HAVE_CRYPT)])
fi
fi
@@ -2184,8 +2185,11 @@ fi
##
if test $with_pam_for_crypt = no; then
AC_CACHE_CHECK([for a crypt that needs truncated salt],samba_cv_HAVE_TRUNCATED_SALT,[
+crypt_LIBS="$LIBS"
+LIBS="$AUTHLIBS $LIBS"
AC_TRY_RUN([#include "${srcdir-.}/tests/crypttest.c"],
- samba_cv_HAVE_TRUNCATED_SALT=no,samba_cv_HAVE_TRUNCATED_SALT=yes,samba_cv_HAVE_TRUNCATED_SALT=cross)])
+ samba_cv_HAVE_TRUNCATED_SALT=no,samba_cv_HAVE_TRUNCATED_SALT=yes,samba_cv_HAVE_TRUNCATED_SALT=cross)
+LIBS="$crypt_LIBS"])
if test x"$samba_cv_HAVE_TRUNCATED_SALT" = x"yes"; then
AC_DEFINE(HAVE_TRUNCATED_SALT)
fi