summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-10-15 19:30:12 +0000
committerJeremy Allison <jra@samba.org>1998-10-15 19:30:12 +0000
commit1cf3444105558f2c55b0c89e725aeb88a0e8add8 (patch)
treecd4aa8e446911dae8ac90ca66c117645e4a946fd /source3/configure.in
parenta42afcdcc7ab9aa9ed193ae36d3dbb10843447f0 (diff)
downloadsamba-1cf3444105558f2c55b0c89e725aeb88a0e8add8.tar.gz
samba-1cf3444105558f2c55b0c89e725aeb88a0e8add8.tar.bz2
samba-1cf3444105558f2c55b0c89e725aeb88a0e8add8.zip
Fixed crypt problems on IRIX with prototype.
Jeremy. (This used to be commit bdba1bcf2094d2b33dd74d3cfde61723dd7fc46b)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index dc036c6238..155c03ec08 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -117,7 +117,7 @@ fi
# stupid glibc has the functions but no declaration. grrrr.
AC_CACHE_CHECK([for setresuid declaration],samba_cv_have_setresuid_decl,[
- AC_TRY_COMPILE([#include <unistd.h>],[int i = setresuid],
+ AC_TRY_COMPILE([#include <unistd.h>],[int i = (int)setresuid],
samba_cv_have_setresuid_decl=yes,samba_cv_have_setresuid_decl=no)])
if test x"$samba_cv_have_setresuid_decl" = x"yes"; then
AC_DEFINE(HAVE_SETRESUID_DECL)
@@ -125,7 +125,7 @@ fi
# stupid glibc has the functions but no declaration. grrrr.
AC_CACHE_CHECK([for crypt declaration],samba_cv_have_crypt_decl,[
- AC_TRY_COMPILE([#include <unistd.h>],[int i = crypt],
+ AC_TRY_COMPILE([#include <unistd.h>],[int i = (int)crypt],
samba_cv_have_crypt_decl=yes,samba_cv_have_crypt_decl=no)])
if test x"$samba_cv_have_crypt_decl" = x"yes"; then
AC_DEFINE(HAVE_CRYPT_DECL)