summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGerald Carter <jerry@samba.org>2003-06-05 02:34:30 +0000
committerGerald Carter <jerry@samba.org>2003-06-05 02:34:30 +0000
commit3bdfd57a2dc590896a2e45652ad4f5e3c2358108 (patch)
treee846066e8dedaa62ffdd6b9e628b8c4f3a8dddc6 /source3/configure.in
parente8d5d89277694daac3ec83ce4f606baedcaa930e (diff)
downloadsamba-3bdfd57a2dc590896a2e45652ad4f5e3c2358108.tar.gz
samba-3bdfd57a2dc590896a2e45652ad4f5e3c2358108.tar.bz2
samba-3bdfd57a2dc590896a2e45652ad4f5e3c2358108.zip
working draft of the idmap_ldap code.
Includes sambaUnixIdPool objectclass Still needs cleaning up wrt to name space. More changes to come, but at least we now have a a working distributed winbindd solution. (This used to be commit 824175854421f7c27d31ad673a8790dd018ae350)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in12
1 files changed, 8 insertions, 4 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 79f01ba421..53b4f1524f 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2302,8 +2302,8 @@ AC_ARG_WITH(ldap,
AC_MSG_RESULT($with_ldap_support)
if test x"$with_ldap_support" = x"yes"; then
-ac_save_LIBS="$LIBS"
-LIBS=""
+ ac_save_LIBS="$LIBS"
+ LIBS=""
##################################################################
# we might need the lber lib on some systems. To avoid link errors
@@ -2322,6 +2322,9 @@ LIBS=""
])
])
+ ## we have ldap so build the list of files for the generic samba ldap library
+ SMBLDAP="lib/smbldap.o"
+
########################################################
# If we have LDAP, does it's rebind procedure take 2 or 3 arguments?
# Check found in pam_ldap 145.
@@ -2334,8 +2337,9 @@ LIBS=""
AC_CHECK_FUNCS(ldap_initialize)
fi
-LDAP_LIBS="$LIBS";
-LIBS="$ac_save_LIBS";
+ AC_SUBST(SMBLDAP)
+ LDAP_LIBS="$LIBS";
+ LIBS="$ac_save_LIBS";
else
# Can't have ADS support without LDAP
if test x"$with_ads_support" = x"yes"; then