summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorRichard Sharpe <sharpe@samba.org>2003-11-06 23:37:58 +0000
committerRichard Sharpe <sharpe@samba.org>2003-11-06 23:37:58 +0000
commit80ff2046bda03cd0336992a5ed7cde9bc8a11b6e (patch)
treef2e6ed9034dd2a61ad976a46b9162fccac75c5cd /source3/configure.in
parent9f154119e8788e9c3525b0a61c64326abd35bdf6 (diff)
downloadsamba-80ff2046bda03cd0336992a5ed7cde9bc8a11b6e.tar.gz
samba-80ff2046bda03cd0336992a5ed7cde9bc8a11b6e.tar.bz2
samba-80ff2046bda03cd0336992a5ed7cde9bc8a11b6e.zip
A fix to allow configure to find iconv on a number of systems including those
that don't have such support in glibc. (This used to be commit de6d5f1d1025bec8991944060df50eb2602f7221)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in13
1 files changed, 10 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 8f0f1c8bfc..db9f3d4598 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1605,9 +1605,8 @@ for i in $LOOK_DIRS ; do
save_CPPFLAGS=$CPPFLAGS
CPPFLAGS="$CPPFLAGS -I$i/include"
dnl This is here to handle -withval stuff for --with-libiconv
- if test x"$ICONV_PATH_SPEC" = "xyes" ; then
- LDFLAGS="-L$i/lib"
- fi
+dnl Perhaps we should always add a -L
+ LDFLAGS="$LDFLAGS -L$i/lib"
LIBS=
export LDFLAGS LIBS CPPFLAGS
dnl Try to find iconv(3)
@@ -1629,6 +1628,9 @@ dnl there might be a working iconv further down the list of LOOK_DIRS
if test x"$ICONV_PATH_SPEC" = "xyes" ; then
LIBS="$LIBS -L$ICONV_LOCATION/lib"
fi
+ if test x"$jm_cv_lib_iconv" != x; then
+ LIBS="$LIBS -l$jm_cv_lib_iconv"
+ fi
dnl AC_CACHE_CHECK([for working iconv],samba_cv_HAVE_NATIVE_ICONV,[
default_dos_charset=no
default_display_charset=no
@@ -1682,6 +1684,11 @@ dnl ])
LIBS="$ic_save_LIBS"
if test x"$samba_cv_HAVE_NATIVE_ICONV" = x"yes"; then
CPPFLAGS=$save_CPPFLAGS
+ LDFLAGS=$save_LDFLAGS
+ LIBS=$save_LIBS
+ if test x"$jm_cv_lib_iconv" != x; then
+ LIBS="$LIBS -l$jm_cv_lib_iconv"
+ fi
CFLAGS_ADD_DIR(CPPFLAGS, "$i/include")
export CPPFLAGS
AC_DEFINE(HAVE_NATIVE_ICONV,1,[Whether to use native iconv])