summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2003-01-19 22:27:32 +0000
committerJeremy Allison <jra@samba.org>2003-01-19 22:27:32 +0000
commit812e093f026a3575f00633c8d4d63b8bdb8a1bcb (patch)
tree9dfb2220e6f57759da6a66340e25e772274cf0d9 /source3/configure.in
parentdd99a6a81619c46ea512076f0ca860748d2fae4a (diff)
downloadsamba-812e093f026a3575f00633c8d4d63b8bdb8a1bcb.tar.gz
samba-812e093f026a3575f00633c8d4d63b8bdb8a1bcb.tar.bz2
samba-812e093f026a3575f00633c8d4d63b8bdb8a1bcb.zip
Merge in more of the SuSE patches for Heimdal. These changes show how
to add a function without an explicit #ifdef HEIMDAL which I'm trying to avoid. Jeremy. (This used to be commit 92ecd0bf0fe2cc4f6c86ca48e6e458e726470a50)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index bf83ff85d6..5c2a659fbd 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2041,6 +2041,10 @@ fi
# Heimdal checks.
AC_CHECK_LIB(crypto, des_set_key, [LIBS="$LIBS -lcrypto"])
AC_CHECK_LIB(asn1, copy_Authenticator, [LIBS="$LIBS -lasn1 -lroken"])
+ AC_CHECK_LIB(krb5, krb5_set_real_time, [AC_DEFINE(HAVE_KRB5_SET_REAL_TIME,1,[Whether krb5_set_real_time is available])])
+ AC_CHECK_LIB(krb5, krb5_set_default_in_tkt_etypes, [AC_DEFINE(HAVE_KRB5_SET_DEFAULT_IN_TKT_ETYPES,1,[Whether krb5_set_default_in_tkt_etypes, is available])])
+ AC_CHECK_LIB(krb5, krb5_set_default_tgs_ktypes, [AC_DEFINE(HAVE_KRB5_SET_DEFAULT_TGS_KTYPES,1,[Whether krb5_set_default_tgs_ktypes is available])])
+
########################################################
# now see if we can find the krb5 libs in standard paths