summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2004-05-13 00:20:50 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 10:51:33 -0500
commit89db7e100193c3b895180730f49061424a806c8e (patch)
tree750f01f8ee5b3bc309c21aea9782cf5986da0629 /source3/configure.in
parenteffc7c0487da4212003e52aab71d1fb727a5aa77 (diff)
downloadsamba-89db7e100193c3b895180730f49061424a806c8e.tar.gz
samba-89db7e100193c3b895180730f49061424a806c8e.tar.bz2
samba-89db7e100193c3b895180730f49061424a806c8e.zip
r656: Make widelinks use realpath(). Tidy up cases where we need to become a service.
Jeremy. (This used to be commit a03b6a05e02ec8415efc0e8ceade102e06f8fffe)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f4383ea337..7d6cfee111 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2277,7 +2277,21 @@ if test x"$samba_cv_BROKEN_NISPLUS_INCLUDE_FILES" = x"yes"; then
AC_DEFINE(BROKEN_NISPLUS_INCLUDE_FILES,1,[Whether the nisplus include files are broken])
fi
+AC_CACHE_CHECK([if the realpath function allows a NULL argument],samba_cv_REALPATH_TAKES_NULL,[
+AC_TRY_RUN([
+#include <stdio.h>
+#include <limits.h>
+main() {
+ char *newpath = realpath("/tmp", NULL);
+ exit ((newpath != NULL) ? 0 : 1);
+}
+],
+samba_cv_REALPATH_TAKES_NULL=yes,samba_cv_REALPATH_TAKES_NULL=no,samba_cv_REALPATH_TAKES_NULL=cross)])
+if test x"$samba_cv_REALPATH_TAKES_NULL" = x"yes"; then
+ AC_DEFINE(REALPATH_TAKES_NULL,1,[Whether the realpath function allows NULL])
+fi
+A
#################################################
# check for smbwrapper support
AC_MSG_CHECKING(whether to use smbwrapper)