summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2002-09-17 01:14:54 +0000
committerTim Potter <tpot@samba.org>2002-09-17 01:14:54 +0000
commit91ba6aa8a84cf13710d7e4783169bc7128142379 (patch)
tree78d00bc1c5a86ab8b120717c6ecf866c1e914a54 /source3/configure.in
parente8ea0aadbb01d824851dfbf2e9122170791b7226 (diff)
downloadsamba-91ba6aa8a84cf13710d7e4783169bc7128142379.tar.gz
samba-91ba6aa8a84cf13710d7e4783169bc7128142379.tar.bz2
samba-91ba6aa8a84cf13710d7e4783169bc7128142379.zip
Default to "python" for --with-python option. This saves having to run
--with-python=python which looks a bit silly. (This used to be commit 130e05de073268cbabed0e2f80f0011e5f72dc02)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 5e742f9498..0e4e910f0c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2919,7 +2919,14 @@ AC_SUBST(FLAGS1)
AC_ARG_WITH(python,
[ --with-python=PYTHONNAME build Python libraries],
-[ PYTHON=${withval-python} ])
+[ case "${withval-python}" in
+ yes)
+ PYTHON=python
+ ;;
+ *)
+ PYTHON=${withval-python}
+ ;;
+ esac ])
AC_SUBST(PYTHON)
#################################################