summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2002-06-16 05:03:11 +0000
committerAndrew Bartlett <abartlet@samba.org>2002-06-16 05:03:11 +0000
commita54afa45be41a46432470b6fa3f29050f09b47ba (patch)
tree7e887467bacc955fcca93a3c519ce2635e05ff8c /source3/configure.in
parent60ad5b69808c0ebfecd13c8f741f4e5687742899 (diff)
downloadsamba-a54afa45be41a46432470b6fa3f29050f09b47ba.tar.gz
samba-a54afa45be41a46432470b6fa3f29050f09b47ba.tar.bz2
samba-a54afa45be41a46432470b6fa3f29050f09b47ba.zip
Two things: Check how many paramaters that the LDAP libs take for the
rebind proc (some give an extra paramter to pass a void* paramater) and some small changes for the SMB signing code to reset things when the signing starts, and to 'turn off' signing if the session setup failed. Andrew Bartlett (This used to be commit a8805a34e5d96eeb5ffe15681b241d5a449a6144)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 6a99e9d4b7..5acdb41028 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1986,6 +1986,16 @@ AC_CHECK_LIB(lber, ber_scanf, [LIBS="$LIBS -llber"])
if test x$have_ldap != xyes; then
AC_CHECK_LIB(ldap, ldap_domain2hostlist, [LIBS="$LIBS -lldap";
AC_DEFINE(HAVE_LDAP)])
+
+ ########################################################
+ # If we have LDAP, does it's rebind procedure take 2 or 3 arguments?
+ # Check found in pam_ldap 145.
+ AC_CHECK_FUNCS(ldap_set_rebind_proc)
+ AC_CACHE_CHECK(whether ldap_set_rebind_proc takes 3 arguments, pam_ldap_cv_ldap_set_rebind_proc, [
+ AC_TRY_COMPILE([
+ #include <lber.h>
+ #include <ldap.h>], [ldap_set_rebind_proc(0, 0, 0);], [pam_ldap_cv_ldap_set_rebind_proc=3], [pam_ldap_cv_ldap_set_rebind_proc=2]) ])
+ AC_DEFINE_UNQUOTED(LDAP_SET_REBIND_PROC_ARGS, $pam_ldap_cv_ldap_set_rebind_proc)
fi
#################################################