summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2002-10-01 05:55:25 +0000
committerJeremy Allison <jra@samba.org>2002-10-01 05:55:25 +0000
commita9ccc38c082c3c74050cbbf554cbef027e585fdd (patch)
treebd66cd06900570569a930bd81ab39cd69461f001 /source3/configure.in
parent3e2a384e765c0702fb34d2f2447bf653dabde185 (diff)
downloadsamba-a9ccc38c082c3c74050cbbf554cbef027e585fdd.tar.gz
samba-a9ccc38c082c3c74050cbbf554cbef027e585fdd.tar.bz2
samba-a9ccc38c082c3c74050cbbf554cbef027e585fdd.zip
Fix Solaris sendfile detection. Add small fixes to sendfile code.
Jeremy. (This used to be commit ef7bcaf1b7e1ca073b27a8836c6aa86e112b5bee)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f19a8ed18c..e9ad6af93e 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2733,12 +2733,14 @@ samba_cv_HAVE_ACL_GET_PERM_NP=yes,samba_cv_HAVE_ACL_GET_PERM_NP=no)])
#################################################
# check for sendfile support
-AC_MSG_CHECKING(whether to support sendfile)
+AC_MSG_CHECKING(whether to check for support sendfile)
AC_ARG_WITH(sendfile-support,
-[ --with-sendfile-support Include sendfile support (default=no)],
+[ --with-sendfile-support Check for sendfile support (default=no)],
[ case "$withval" in
yes)
+ AC_MSG_RESULT(yes);
+
case "$host_os" in
*linux*)
AC_CACHE_CHECK([for linux sendfile64 support],samba_cv_HAVE_SENDFILE64,[
@@ -2884,6 +2886,7 @@ samba_cv_HAVE_SENDFILE=yes,samba_cv_HAVE_SENDFILE=no)])
size_t xferred;
struct sendfilevec vec[2];
ssize_t nwritten;
+ int tofd;
sfvcnt = 2;
@@ -2916,6 +2919,7 @@ samba_cv_HAVE_SENDFILEV64=yes,samba_cv_HAVE_SENDFILEV64=no)])
size_t xferred;
struct sendfilevec vec[2];
ssize_t nwritten;
+ int tofd;
sfvcnt = 2;