summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2004-06-17 21:23:56 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 10:51:58 -0500
commitaf10abdd5515b7458bab7f82871bd4a3a450a7de (patch)
treed8d3920d625c2b2e2f09c488275984039601e226 /source3/configure.in
parent5be2af482253306b0a1ddbdb813d928664f5a622 (diff)
downloadsamba-af10abdd5515b7458bab7f82871bd4a3a450a7de.tar.gz
samba-af10abdd5515b7458bab7f82871bd4a3a450a7de.tar.bz2
samba-af10abdd5515b7458bab7f82871bd4a3a450a7de.zip
r1179: Start of system keytab merge. Config tests.
Jeremy. (This used to be commit 730d750c045a762d54a6ce3df94c871231dc6596)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in35
1 files changed, 35 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 065587640c..6975c62b39 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2713,6 +2713,7 @@ if test x"$with_ads_support" != x"no"; then
# now see if we can find the krb5 libs in standard paths
# or as specified above
AC_CHECK_LIB_EXT(krb5, KRB5_LIBS, krb5_mk_req_extended)
+ AC_CHECK_LIB_EXT(krb5, KRB5_LIBS, krb5_kt_compare)
########################################################
# now see if we can find the gssapi libs in standard paths
@@ -2817,6 +2818,18 @@ if test x"$with_ads_support" != x"no"; then
[Whether the AP_OPTS_USE_SUBKEY ap option is available])
fi
+ AC_CACHE_CHECK([for KV5M_KEYTAB],
+ samba_cv_HAVE_KV5M_KEYTAB,[
+ AC_TRY_COMPILE([#include <krb5.h>],
+ [krb5_keytab_entry entry; entry.magic = KV5M_KEYTAB;],
+ samba_cv_HAVE_KV5M_KEYTAB=yes,
+ samba_cv_HAVE_KV5M_KEYTAB=no)])
+
+ if test x"$samba_cv_HAVE_KV5M_KEYTAB" = x"yes"; then
+ AC_DEFINE(HAVE_KV5M_KEYTAB,1,
+ [Whether the KV5M_KEYTAB option is available])
+ fi
+
AC_CACHE_CHECK([for the krb5_princ_component macro],
samba_cv_HAVE_KRB5_PRINC_COMPONENT,[
AC_TRY_LINK([#include <krb5.h>],
@@ -2954,6 +2967,28 @@ AC_ARG_WITH(smbmount,
AC_MSG_RESULT(no)
)
+AC_CACHE_CHECK([for WRFILE: keytab support],
+ samba_cv_HAVE_WRFILE_KEYTAB,[
+ AC_TRY_RUN([
+#include<krb5.h>
+ main()
+ {
+ krb5_context context;
+ krb5_keytab keytab;
+
+ krb5_init_context(&context);
+ if (krb5_kt_resolve(context, "WRFILE:api", &keytab))
+ exit(0);
+ exit(1);
+ }],
+ samba_cv_HAVE_WRFILE_KEYTAB=no,
+ samba_cv_HAVE_WRFILE_KEYTAB=yes)])
+
+ if test x"$samba_cv_HAVE_WRFILE_KEYTAB" = x"yes"; then
+ AC_DEFINE(HAVE_WRFILE_KEYTAB,1,
+ [Whether the WRFILE:-keytab is supported])
+ fi
+
#################################################
# check for a PAM clear-text auth, accounts, password and session support