summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2003-03-26 19:39:27 +0000
committerJeremy Allison <jra@samba.org>2003-03-26 19:39:27 +0000
commitb39659bcbe61812c3c4616eb2404bf9e4d768366 (patch)
tree756ef6167b342cfa5bb0820f1f9aa9d16de13394 /source3/configure.in
parent5ab2abd707b3a81b8c28813ebe2fd0b2ae1112a7 (diff)
downloadsamba-b39659bcbe61812c3c4616eb2404bf9e4d768366.tar.gz
samba-b39659bcbe61812c3c4616eb2404bf9e4d768366.tar.bz2
samba-b39659bcbe61812c3c4616eb2404bf9e4d768366.zip
Add defines for platforms that need them.
Jeremy. (This used to be commit 7787815da498382a380230912e0573f41347d0d8)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 344ce2e350..b55a2b185e 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1020,6 +1020,7 @@ if test "$enable_shared" = "yes"; then
PICSUFFIX="po.o"
fi
AC_DEFINE(STAT_ST_BLOCKSIZE,512,[The size of a block])
+ AC_DEFINE(BROKEN_GETGRNAM,1,[Does getgrnam work correctly])
;;
*sunos*) AC_DEFINE(SUNOS4,1,[Whether the host os is sunos4])
BLDSHARED="true"
@@ -1027,6 +1028,7 @@ if test "$enable_shared" = "yes"; then
SONAMEFLAG="-Wl,-h,"
PICFLAG="-KPIC" # Is this correct for SunOS
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
+ AC_DEFINE(BROKEN_GETGRNAM,1,[Does getgrnam work correctly])
;;
*netbsd* | *freebsd*) BLDSHARED="true"
LDSHFLAGS="-shared"
@@ -1034,6 +1036,7 @@ if test "$enable_shared" = "yes"; then
SONAMEFLAG="-Wl,-soname,"
PICFLAG="-fPIC -DPIC"
AC_DEFINE(STAT_ST_BLOCKSIZE,512,[The size of a block])
+ AC_DEFINE(BROKEN_GETGRNAM,1,[Does getgrnam work correctly])
;;
*openbsd*) BLDSHARED="true"
LDSHFLAGS="-shared"
@@ -1041,6 +1044,7 @@ if test "$enable_shared" = "yes"; then
SONAMEFLAG="-Wl,-soname,"
PICFLAG="-fPIC"
AC_DEFINE(STAT_ST_BLOCKSIZE,512,[The size of a block])
+ AC_DEFINE(BROKEN_GETGRNAM,1,[Does getgrnam work correctly])
;;
*irix*) AC_DEFINE(IRIX,1,[Whether the host os is irix])
case "$host_os" in
@@ -1083,6 +1087,7 @@ if test "$enable_shared" = "yes"; then
fi
DYNEXP="-Wl,-E"
AC_DEFINE(STAT_ST_BLOCKSIZE,8192,[The size of a block])
+ AC_DEFINE(POSIX_ACL_NEEDS_MASK,1,[Does a POSIX ACL need a mask element])
;;
*qnx*) AC_DEFINE(QNX,1,[Whether the host os is qnx])
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
@@ -1093,6 +1098,7 @@ if test "$enable_shared" = "yes"; then
SONAMEFLAG="-Wl,-soname,"
PICFLAG="-fPIC"
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
+ AC_DEFINE(BROKEN_GETGRNAM,1,[Does getgrnam work correctly])
;;
*sco*) AC_DEFINE(SCO,1,[Whether the host os is sco unix])
AC_DEFINE(STAT_ST_BLOCKSIZE,512)