summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authortodd stecher <todd.stecher@gmail.com>2009-02-08 23:12:02 -0800
committerTim Prouty <tprouty@samba.org>2009-02-09 13:23:44 -0800
commitf8c0d2fe010e06bed02fab7f51e000907535416a (patch)
tree4b014de586dd9d11398b2ec99db2311f8eb3960d /source3/configure.in
parent54c51a66e3e31c70a641d7efac2d4b08c3007278 (diff)
downloadsamba-f8c0d2fe010e06bed02fab7f51e000907535416a.tar.gz
samba-f8c0d2fe010e06bed02fab7f51e000907535416a.tar.bz2
samba-f8c0d2fe010e06bed02fab7f51e000907535416a.zip
S3 OneFS: Add in Isilon specific performance counter module
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 86fb84c37e..b81e768073 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1097,7 +1097,7 @@ AC_TRY_LINK([#include <isi_version/isi_version.h>],
echo $samba_cv_HAVE_ONEFS
if test x"$samba_cv_HAVE_ONEFS" = x"yes"; then
AC_DEFINE(HAVE_ONEFS,1,[Whether building on Isilon OneFS])
- default_shared_modules="$default_shared_modules vfs_onefs"
+ default_shared_modules="$default_shared_modules vfs_onefs perfcount_onefs"
ONEFS_LIBS="-lisi_acl"
fi
AC_SUBST(ONEFS_LIBS)
@@ -6416,8 +6416,10 @@ SMB_MODULE(vfs_acl_xattr, \$(VFS_ACL_XATTR_OBJ), "bin/acl_xattr.$SHLIBEXT", VFS)
SMB_MODULE(vfs_acl_tdb, \$(VFS_ACL_TDB_OBJ), "bin/acl_tdb.$SHLIBEXT", VFS)
SMB_MODULE(vfs_smb_traffic_analyzer, \$(VFS_SMB_TRAFFIC_ANALYZER_OBJ), "bin/smb_traffic_analyzer.$SHLIBEXT", VFS)
SMB_MODULE(vfs_onefs, \$(VFS_ONEFS), "bin/onefs.$SHLIBEXT", VFS)
+
SMB_SUBSYSTEM(VFS,smbd/vfs.o)
+SMB_MODULE(perfcount_onefs, \$(PERFCOUNT_ONEFS), "bin/pc_onefs.$SHLIBEXT", PERFCOUNT)
SMB_SUBSYSTEM(PERFCOUNT,smbd/perfcount.o)
SMB_MODULE(gpext_registry, libgpo/gpext/registry.o, "bin/registry.$SHLIBEXT", GPEXT)