summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2003-04-14 01:10:49 +0000
committerTim Potter <tpot@samba.org>2003-04-14 01:10:49 +0000
commitfe5b2c15dedc399fa800c14c8f72b9c681bf77ac (patch)
treeb70a7409c443d0fe6514a2305f530d722778c6e2 /source3/configure.in
parentb30de2567bf6b84742494078e99e6cb641844db9 (diff)
downloadsamba-fe5b2c15dedc399fa800c14c8f72b9c681bf77ac.tar.gz
samba-fe5b2c15dedc399fa800c14c8f72b9c681bf77ac.tar.bz2
samba-fe5b2c15dedc399fa800c14c8f72b9c681bf77ac.zip
Merge a bunch of updates from HEAD:
- winbind nss client cleanups - new rpc echo pipe (This used to be commit ea38b0d7f0b05565bab341294f11d53f0b6f7809)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index d6ed8fac62..233cf852d6 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -193,6 +193,10 @@ AC_SUBST(DFS_DYNAMIC_YES)
AC_SUBST(DFS_DYNAMIC_NO)
DFS_DYNAMIC_YES="#"
DFS_DYNAMIC_NO=
+AC_SUBST(ECHO_DYNAMIC_YES)
+AC_SUBST(ECHO_DYNAMIC_NO)
+ECHO_DYNAMIC_YES="#"
+ECHO_DYNAMIC_NO=
# compile with optimization and without debugging by default
CFLAGS="-O ${CFLAGS}"
@@ -273,6 +277,11 @@ then
DFS_DYNAMIC_NO="#"
AC_DEFINE(RPC_DFS_DYNAMIC, 1,
[Define to make the NETDFS pipe dynamic])
+ ;; echo)
+ ECHO_DYNAMIC_YES=
+ ECHO_DYNAMIC_NO="#"
+ AC_DEFINE(RPC_ECHO_DYNAMIC, 1,
+ [Define to make the ECHO pipe dynamic])
;; esac
done
fi
@@ -3267,12 +3276,19 @@ AC_MSG_CHECKING(whether to build winbind)
HAVE_WINBIND=yes
+# Define the winbind shared library name and any specific linker flags
+# it needs to be built with.
+
+WINBIND_NSS=libnss_winbind
+WINBIND_NSS_LDSHFLAGS=$LDSHFLAGS
+
case "$host_os" in
*linux*)
WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_linux.o"
;;
*irix*)
WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_irix.o"
+ WINBIND_NSS="libns_winbind"
;;
*solaris*)
# Solaris winbind client is implemented as a wrapper around
@@ -3286,6 +3302,7 @@ case "$host_os" in
;;
*aix*)
WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_aix.o"
+ WINBIND_NSS_LDSHFLAGS="-Wl,-bexpall,-bM:SRE,-ewb_aix_init"
;;
*)
HAVE_WINBIND=no
@@ -3293,6 +3310,8 @@ case "$host_os" in
;;
esac
+AC_SUBST(WINBIND_NSS)
+AC_SUBST(WINBIND_NSS_LDSHFLAGS)
AC_SUBST(WINBIND_NSS_EXTRA_OBJS)
AC_SUBST(WINBIND_NSS_EXTRA_LIBS)