summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorBjörn Jacke <bj@sernet.de>2009-01-29 00:33:19 +0100
committerJeremy Allison <jra@samba.org>2009-01-29 09:51:36 -0800
commit11f32204f8e6c5e90e8e242116d3f74808184884 (patch)
tree519762c51c3a15299cbbce3f257d345053e1d242 /source3/configure.in
parentf9926a4944171759cdd129ae07962765d658f711 (diff)
downloadsamba-11f32204f8e6c5e90e8e242116d3f74808184884.tar.gz
samba-11f32204f8e6c5e90e8e242116d3f74808184884.tar.bz2
samba-11f32204f8e6c5e90e8e242116d3f74808184884.zip
add configure check for AIX style sub-second resolution support
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in44
1 files changed, 42 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4ce9207a9e..f44fb9b8c4 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1395,7 +1395,7 @@ if test x"$samba_cv_stat_hires" = x"yes" ; then
[whether struct stat has sub-second timestamps])
fi
-AC_CACHE_CHECK([whether struct stat has sub-second timestamps without struct timespec], samba_cv_stat_hires_notimespec,
+AC_CACHE_CHECK([whether struct stat has sub-second timestamps without struct timespec suffixed nsec], samba_cv_stat_hires_notimespec,
[
AC_TRY_COMPILE(
[
@@ -1431,7 +1431,47 @@ if test x"$samba_cv_stat_hires_notimespec" = x"yes" ; then
AC_DEFINE(HAVE_STAT_ST_ATIMENSEC, 1, [whether struct stat contains st_atimensec])
AC_DEFINE(HAVE_STAT_ST_CTIMENSEC, 1, [whether struct stat contains st_ctimensec])
AC_DEFINE(HAVE_STAT_HIRES_TIMESTAMPS, 1,
- [whether struct stat has sub-second timestamps without struct timespec])
+ [whether struct stat has sub-second timestamps without struct timespec suffixed nsec])
+fi
+
+dnl AIX stype sub-second timestamps:
+AC_CACHE_CHECK([whether struct stat has sub-second timestamps without struct timespec suffixed _n], samba_cv_stat_hires_notimespec_n,
+ [
+ AC_TRY_COMPILE(
+ [
+#if TIME_WITH_SYS_TIME
+# include <sys/time.h>
+# include <time.h>
+#else
+# if HAVE_SYS_TIME_H
+# include <sys/time.h>
+# else
+# include <time.h>
+# endif
+#endif
+#ifdef HAVE_SYS_STAT_H
+#include <sys/stat.h>
+#endif
+ ],
+ [
+ struct timespec t;
+ struct stat s = {0};
+ t.tv_sec = s.st_mtime;
+ t.tv_nsec = s.st_mtime_n;
+ t.tv_sec = s.st_ctime;
+ t.tv_nsec = s.st_ctime_n;
+ t.tv_sec = s.st_atime;
+ t.tv_nsec = s.st_atime_n;
+ ],
+ samba_cv_stat_hires_notimespec_n=yes, samba_cv_stat_hires_notimespec_n=no)
+ ])
+
+if test x"$samba_cv_stat_hires_notimespec_n" = x"yes" ; then
+ AC_DEFINE(HAVE_STAT_ST_MTIME_N, 1, [whether struct stat contains st_mtime_n])
+ AC_DEFINE(HAVE_STAT_ST_ATIME_N, 1, [whether struct stat contains st_atime_n])
+ AC_DEFINE(HAVE_STAT_ST_CTIME_N, 1, [whether struct stat contains st_ctime_n])
+ AC_DEFINE(HAVE_STAT_HIRES_TIMESTAMPS, 1,
+ [whether struct stat has sub-second timestamps without struct timespec suffixed _n])
fi
AC_CACHE_CHECK([whether struct stat has st_birthtimespec], samba_cv_stat_st_birthtimespec,