summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2002-01-08 04:44:15 +0000
committerAndrew Tridgell <tridge@samba.org>2002-01-08 04:44:15 +0000
commit1803e9cc0f1123b6dc8004a39b4635ac7ed2a983 (patch)
tree8f3e3a2e7284dbc94e24c52f6ce3466620140e07 /source3/configure.in
parentb19ec04f5228b76bc7953e5f8fc6d820ee610dfe (diff)
downloadsamba-1803e9cc0f1123b6dc8004a39b4635ac7ed2a983.tar.gz
samba-1803e9cc0f1123b6dc8004a39b4635ac7ed2a983.tar.bz2
samba-1803e9cc0f1123b6dc8004a39b4635ac7ed2a983.zip
- fixed my breakage of CPPFLAGS
- allow winbindd and wbinfo to build without shared libraries (This used to be commit d5db2518be8458f24f66eaa17434504b994ebb9a)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in22
1 files changed, 11 insertions, 11 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 2340a1129c..32e4836e9f 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2538,25 +2538,25 @@ fi
# Display test results
-if test x"$HAVE_WINBIND" = x"yes" && test x"$BLDSHARED" = x"true"; then
+WINBIND_TARGETS=""
+WINBIND_STARGETS=""
+WINBIND_LTARGETS=""
+WINBIND_PAM_PROGS=""
+
+if test x"$HAVE_WINBIND" = x"yes"; then
AC_MSG_RESULT(yes)
WINBIND_TARGETS="bin/wbinfo"
WINBIND_STARGETS="bin/winbindd"
- WINBIND_LTARGETS="nsswitch/libnss_winbind.so"
- case "$with_pam" in
- yes)
+ if test x"$BLDSHARED" = x"true"; then
+ WINBIND_LTARGETS="nsswitch/libnss_winbind.so"
+ if test x"$with_pam" = x"yes"; then
WINBIND_PAM_TARGETS="nsswitch/pam_winbind.so"
- ;;
- esac
+ fi
+ fi
else
AC_MSG_RESULT(no$winbind_no_reason)
-
- WINBIND_TARGETS=""
- WINBIND_STARGETS=""
- WINBIND_LTARGETS=""
- WINBIND_PAM_PROGS=""
fi
# Substitution time!