summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2002-03-01 01:03:06 +0000
committerJeremy Allison <jra@samba.org>2002-03-01 01:03:06 +0000
commit2853554cdb5ffd162699f2f50e65f6d5a766cacc (patch)
tree2df8e0684fc8c6fbe81b28fb05f0f30e80120d30 /source3/configure.in
parent121d3238d72adc20bc08418d30eca1d41b4ff749 (diff)
downloadsamba-2853554cdb5ffd162699f2f50e65f6d5a766cacc.tar.gz
samba-2853554cdb5ffd162699f2f50e65f6d5a766cacc.tar.bz2
samba-2853554cdb5ffd162699f2f50e65f6d5a766cacc.zip
Attempt to fix Solaris winbind nss build.
Jeremy. (This used to be commit 10e3e6855be93b8c4d97d67a063d92ccee391fec)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in23
1 files changed, 17 insertions, 6 deletions
diff --git a/source3/configure.in b/source3/configure.in
index e700305283..9288f1cff5 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2572,14 +2572,23 @@ AC_MSG_CHECKING(whether to build winbind)
# Initially, the value of $host_os decides whether winbind is supported
-case "$host_os" in
- *linux*|*solaris*|*irix*)
+case "$host_os" in
+ *linux*|*irix*)
HAVE_WINBIND=yes
- ;;
- *)
+ ;;
+ *solaris*)
+ HAVE_WINBIND=yes
+ WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_solaris"
+ WINBIND_NSS_EXTGRA_LIBS="-lsocket"
+ ;;
+ *hpux11*)
+ HAVE_WINBIND=yes
+ WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_solaris"
+ ;;
+ *)
HAVE_WINBIND=no
- winbind_no_reason=", unsupported on $host_os"
- ;;
+ winbind_no_reason=", unsupported on $host_os"
+ ;;
esac
# Check the setting of --with-winbindd
@@ -2635,6 +2644,8 @@ AC_SUBST(WINBIND_TARGETS)
AC_SUBST(WINBIND_STARGETS)
AC_SUBST(WINBIND_LTARGETS)
AC_SUBST(WINBIND_PAM_TARGETS)
+AC_SUBST(WINBIND_NSS_EXTRA_OBJS)
+AC_SUBST(WINBIND_NSS_EXTRA_LIBS)
#################################################
# Check to see if we should use the included popt