summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2001-09-25 05:08:05 +0000
committerAndrew Bartlett <abartlet@samba.org>2001-09-25 05:08:05 +0000
commit2bfd6d56cdfd3b0590b4f8dd292e0c23e6d4b277 (patch)
tree69b8ba56cb538ed9db6986b947339c70e7978673 /source3/configure.in
parentc386d8bdd0fc4e29be2e7acc61e5ee84fd52d1f9 (diff)
downloadsamba-2bfd6d56cdfd3b0590b4f8dd292e0c23e6d4b277.tar.gz
samba-2bfd6d56cdfd3b0590b4f8dd292e0c23e6d4b277.tar.bz2
samba-2bfd6d56cdfd3b0590b4f8dd292e0c23e6d4b277.zip
Change ./configure.developer to stay in effect across a
'./config.status --recheck' by making it a real configure option. reran autoconf (This used to be commit 23173125cd124508a080cfc11436273efcbeedb6)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index b9e8c94b42..3bd8995fd7 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -23,11 +23,15 @@ AC_SUBST(LIBSMBCLIENT_SHARED)
# compile with optimisation and without debugging by default
CFLAGS="-O ${CFLAGS}"
-AC_ARG_ENABLE(debug, [ --enable-debug turn on debugging [default=no]],
+AC_ARG_ENABLE(debug, [ --enable-debug turn on debugging [default=no]],
[if eval "test x$enable_debug = xyes"; then
CFLAGS="${CFLAGS} -g"
fi])
+AC_ARG_ENABLE(developer, [ --enable-developer turn on developer warnings and debugging [default=no]],
+ [if eval "test x$enable_developer = xyes"; then
+ CFLAGS="${CFLAGS} -g -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -DDEBUG_PASSWORD -DDEVELOPER"
+ fi])
dnl Checks for programs.
AC_PROG_CC