summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2001-11-27 01:45:08 +0000
committerAndrew Tridgell <tridge@samba.org>2001-11-27 01:45:08 +0000
commit3dc6fe1fe471c6924fcf48be98ad2e9bfbb33357 (patch)
tree33b6b8206dd94f5638667e5baf51c01a5f0dc2c6 /source3/configure.in
parent3d9f2aa3884e7bd1f26f6ad5ec0679481775693c (diff)
downloadsamba-3dc6fe1fe471c6924fcf48be98ad2e9bfbb33357.tar.gz
samba-3dc6fe1fe471c6924fcf48be98ad2e9bfbb33357.tar.bz2
samba-3dc6fe1fe471c6924fcf48be98ad2e9bfbb33357.zip
automatically look for /usr/kerberos to make redhat happy
(This used to be commit 0120dea7f0a799ed5cf43179462973e7a9a01bd3)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 617453c211..a2706769e6 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1606,6 +1606,17 @@ AC_ARG_WITH(dfs,
#################################################
+# see if this box has the RedHat location for kerberos
+AC_MSG_CHECKING(for /usr/kerberos)
+if test -d /usr/kerberos; then
+ LDFLAGS="$LDFLAGS -L/usr/kerberos/lib"
+ CFLAGS="$CFLAGS -I/usr/kerberos/include"
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+
+#################################################
# check for location of Kerberos 5 install
AC_MSG_CHECKING(for kerberos 5 install path)
AC_ARG_WITH(krb5,