summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorDan Sledz <dsledz@isilon.com>2008-11-16 17:40:03 -0800
committerTim Prouty <tprouty@samba.org>2008-11-24 15:34:33 -0800
commit417f187645de49ab35d2918c3ca0185a452e32b1 (patch)
tree9d37bcee4a268db8a6e44d0f459d4e985b3aedc2 /source3/configure.in
parent2c458935933daf219be276b06c6eb1b5752f2638 (diff)
downloadsamba-417f187645de49ab35d2918c3ca0185a452e32b1.tar.gz
samba-417f187645de49ab35d2918c3ca0185a452e32b1.tar.bz2
samba-417f187645de49ab35d2918c3ca0185a452e32b1.zip
Allow SYSLOG_FACILITY to be modified with a new configure option called --with-syslog-facility
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 9214d031b3..90339d770c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -4369,6 +4369,22 @@ AC_ARG_WITH(syslog,
)
#################################################
+# check for custom syslog facility
+AC_MSG_CHECKING(whether to use a custom syslog facility)
+AC_ARG_WITH(syslog-facility,
+[AS_HELP_STRING([--with-syslog-facility], [Use a custom syslog facility (default=none)])],
+[
+ if test "$withval" = "no" ; then
+ AC_MSG_ERROR([argument to --with-syslog-facility must be a string])
+ else
+ if test "$withval" != "yes" ; then
+ syslog_facility="$withval"
+ AC_DEFINE_UNQUOTED(SYSLOG_FACILITY,$syslog_facility, [syslog facility to log to])
+ fi
+ fi
+])
+
+#################################################
# check for experimental disk-quotas support
samba_cv_WITH_QUOTAS=auto