summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorStefan Metzmacher <metze@samba.org>2007-04-17 10:07:12 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:19:25 -0500
commit5064a6c973a82553c5a0de11145be10fe5b2b9e5 (patch)
treeb17d8008a065fd5394ffcf457d962fb1b521267f /source3/configure.in
parent597fd754d78a5ea82c59c71be3e278c416def374 (diff)
downloadsamba-5064a6c973a82553c5a0de11145be10fe5b2b9e5.tar.gz
samba-5064a6c973a82553c5a0de11145be10fe5b2b9e5.tar.bz2
samba-5064a6c973a82553c5a0de11145be10fe5b2b9e5.zip
r22302: fix the build when no shared-library support is detected
metze (This used to be commit 9ad4098910bbfd86ff050b9778301772a622f74d)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 6cf72a4477..77704ac85a 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -297,6 +297,7 @@ AC_SUBST(LDAP_LIBS)
AC_SUBST(PAM_MODULES)
AC_SUBST(INSTALL_PAM_MODULES)
AC_SUBST(UNINSTALL_PAM_MODULES)
+AC_SUBST(NSS_MODULES)
AC_SUBST(EXTRA_BIN_PROGS)
AC_SUBST(SMBMOUNT_PROGS)
AC_SUBST(CIFSMOUNT_PROGS)
@@ -5784,6 +5785,10 @@ AC_SUBST(WINBIND_NSS_EXTRA_OBJS)
AC_SUBST(WINBIND_NSS_EXTRA_LIBS)
AC_SUBST(NSSSONAMEVERSIONSUFFIX)
+if test $BLDSHARED = true -a x"$HAVE_WINBIND" = x"yes"; then
+ NSS_MODULES="${WINBIND_NSS} ${WINBIND_WINS_NSS}"
+fi
+
AC_SUBST(SMB_KRB5_LOCATOR)
# Check the setting of --with-winbind