summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vl@samba.org>2010-05-23 11:44:30 +0200
committerVolker Lendecke <vl@samba.org>2010-05-23 12:44:43 +0200
commit6e7d39f4dd29d090244a51df9f59a42d7cb060d5 (patch)
treeedcfa870dcf3978b653147f065aa934dfff3dbdf /source3/configure.in
parent7eff96cb43587f03a6735e99492be6d775c5d7ef (diff)
downloadsamba-6e7d39f4dd29d090244a51df9f59a42d7cb060d5.tar.gz
samba-6e7d39f4dd29d090244a51df9f59a42d7cb060d5.tar.bz2
samba-6e7d39f4dd29d090244a51df9f59a42d7cb060d5.zip
s3: Another non-gnumake fix
AC_OUTPUT_COMMANDS must be called before AC_OUTPUT and $MAKEFILE is not defined in ./config.status
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in13
1 files changed, 7 insertions, 6 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 885b086dcb..8edb86a4e7 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -6759,6 +6759,13 @@ AC_SUBST(SMBD_LIBS)
CFLAGS="${CFLAGS} \$(FLAGS)"
CFLAGS="${CFLAGS} -D_SAMBA_BUILD_=3"
+# If we had to expand the includes, make tsure the output file is moved back
+AC_OUTPUT_COMMANDS([
+if test -f Makefile-noincludes -a ! -f Makefile -a ! -h Makefile ; then
+ ln -s Makefile-noincludes Makefile
+fi
+])
+
AC_SUBST(MAKEFILE)
if test x$samba_cv_gnu_make = xyes; then
MAKEFILE=Makefile
@@ -6779,12 +6786,6 @@ AC_OUTPUT($MAKEFILE
pkgconfig/smbsharemodes.pc
../examples/libsmbclient/Makefile.internal
)
-dnl If we had to expand the includes, make tsure the output file is moved back
-AC_OUTPUT_COMMANDS([
-if test x$MAKEFILE != Makefile; then
- mv $MAKEFILE Makefile
-fi
-])
#################################################
# Print very concise instructions on building/use