summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorRichard Sharpe <sharpe@samba.org>2001-06-29 23:30:01 +0000
committerRichard Sharpe <sharpe@samba.org>2001-06-29 23:30:01 +0000
commit7e7c258e0b281acf99b3f538cd46f42ce5dfa486 (patch)
treee8d64acb73e58d3e649cb9555d8c5ab7a89708b6 /source3/configure.in
parent8d0b9cf534bc2a219ff4fc47ab139efa994cd7d6 (diff)
downloadsamba-7e7c258e0b281acf99b3f538cd46f42ce5dfa486.tar.gz
samba-7e7c258e0b281acf99b3f538cd46f42ce5dfa486.tar.bz2
samba-7e7c258e0b281acf99b3f538cd46f42ce5dfa486.zip
These changes cause the libsmbclient stuff to always build a non-shared library and to build a shared library only for the four OSes that we currently like.
I will probably add HP/UX and AIX support based on the CUPS stuff soon ... (This used to be commit 9585529455ae4a3e9b4dafc5f16286fabb052809)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 0d59ee50e2..231c1e1e09 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -15,6 +15,7 @@ AC_SUBST(WRAP)
AC_SUBST(WRAP32)
AC_SUBST(PICFLAG)
AC_SUBST(SHLIBEXT)
+AC_SUBST(BLDSHARED)
# compile with optimisation and without debugging by default
CFLAGS="-O ${CFLAGS}"
@@ -607,17 +608,22 @@ HOST_OS="$host_os"
LDSHFLAGS="-shared"
PICFLAG=""
SHLIBEXT="so"
+BLDSHARED="false"
# and these are for particular systems
case "$host_os" in
- *linux*) AC_DEFINE(LINUX);;
+ *linux*) AC_DEFINE(LINUX)
+ BLDSHARED="true"
+ ;;
*solaris*) AC_DEFINE(SUNOS5)
LDSHFLAGS="-G"
+ BLDSHARED="true"
;;
*sunos*) AC_DEFINE(SUNOS4)
LDSHFLAGS=""
;;
*bsd*) LDSHFLAGS="-shared -Bshareable"
+ BLDSHARED="true"
;;
*irix*) AC_DEFINE(IRIX)
case "$host_os" in