summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorRichard Sharpe <sharpe@samba.org>2001-05-17 02:52:42 +0000
committerRichard Sharpe <sharpe@samba.org>2001-05-17 02:52:42 +0000
commit94f68abb7c65cd21cf817964294c7cd89910aa81 (patch)
tree17a0538180a76574ebcb98b1e9ddd4310cab367c /source3/configure.in
parent2378ba1c214e8c377516fd9d5dd10afec6493be3 (diff)
downloadsamba-94f68abb7c65cd21cf817964294c7cd89910aa81.tar.gz
samba-94f68abb7c65cd21cf817964294c7cd89910aa81.tar.bz2
samba-94f68abb7c65cd21cf817964294c7cd89910aa81.zip
Ohh boy, I should be working on lots of other things, but I am pissed off, so
I needed to get down and dirty and do some coding etc ... Change -fpic to -fPIC ... Many people suggest that this is better ... (This used to be commit 26eda1f2b065482d0b547f3068c78ae442ba18d9)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 5c88496509..aab31d06a7 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -657,10 +657,10 @@ case "$host_os" in
;;
esac
-# try to work out how to produce pic code with this compiler
-AC_PROG_CC_FLAG(fpic)
-if test $ac_cv_prog_cc_fpic = yes; then
- PICFLAG="-fpic";
+# try to work out how to produce PIC code with this compiler
+AC_PROG_CC_FLAG(fPIC)
+if test $ac_cv_prog_cc_fPIC = yes; then
+ PICFLAG="-fPIC";
fi
if test x$PICFLAG = x; then
AC_PROG_CC_FLAG(KPIC)