summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorHerb Lewis <herb@samba.org>2001-04-06 18:37:55 +0000
committerHerb Lewis <herb@samba.org>2001-04-06 18:37:55 +0000
commita01d164a12191fba335d64e21ef16d3047c9d907 (patch)
tree541aa44c5196bb49903d1dd5f80385ac847d66f1 /source3/configure.in
parent97cf9d3a3de4d005477ee07423b7d9c34d6d1761 (diff)
downloadsamba-a01d164a12191fba335d64e21ef16d3047c9d907.tar.gz
samba-a01d164a12191fba335d64e21ef16d3047c9d907.tar.bz2
samba-a01d164a12191fba335d64e21ef16d3047c9d907.zip
keep cflags from being duplicated if defined in environment
(This used to be commit 2097298565b367157a3bc0c1178f17b1a6bbdd86)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 9143cf278e..6b84c69ef6 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -16,7 +16,13 @@ AC_SUBST(PICFLAG)
AC_SUBST(SHLIBEXT)
# compile with optimisation and without debugging by default
-CFLAGS=${CFLAGS-"-O"}
+CFLAGS="-O ${CFLAGS}"
+
+AC_ARG_ENABLE(debug, [ --enable-debug turn on debugging [default=no]],
+ [if eval "test x$enable_debug = xyes"; then
+ CFLAGS="${CFLAGS} -g"
+ fi])
+
dnl Checks for programs.
AC_PROG_CC